[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#279098: Install on Alpha XS1000 and 500au

clone 279098 -1
clone 279098 -2
reassign -1 aboot-installer
reassign -2 srm-reader

On Sun, Oct 31, 2004 at 05:39:24PM +0000, Martin Michlmayr wrote:

> I installed on two Alpha machines, an XS1000 and an 500au.  I didn't know
> anything about Alpha when I started, so I used the installation manual to
> find out what I need to do.  First of all, boot-installer/alpha.xml refers
> to MILO which I think is not in Debian anymore.  If this is no longer
> supported, this should be removed (fortunately I had some machines with
> SRM).

Yep, I've started working on updating the documentation this week (finally),
so the references to MILO should be remedied soon.

> Unfortunately, the "boot ewa0 -flags 0" suggested there doesn't work.  When
> I tried this, I got something like:
> VFS: Mounted root (ext2 filesystem).
> attempt to access beyond end of device
> 01:00: rw=0, want=10472, limit=8192
> attempt to access beyond end of device
> 01:00: rw=0, want=10472, limit=8192
> VFS: Cannot open root device "" or 08:02
> Please append a correct "root=" boot option
> Kernel panic: VFS: Unable to mount root fs on 08:02

> After adding a ramdisk_size=16384, it would complain that it cannot find
> root.  When I used
>    boot ewa0 -flags "console=ttyS0 ramdisk_size=16384 root=/dev/ram0"
> it worked.

The serial console examples have been updated in the manual.

> The next thing was that the default language was Albanian (the first in the
> list).

Hrm... this could be an srm-reader bug, it should be able to grab a sensible
language default from the SRM settings... what does the language default to
on other archs?

> The installation went smoothly; I used the guided partitioner, etc.
> After rebooting, it automatically tried to boot from the net ("boot
> ewa0. -flags a"); this is very strange considering that originally
> the machine was configured to boot from disk.  Anyway, after a while I
> figured out I need:
>   boot dka0 -flags console=ttyS0   (or "dkc0" on another machine)
> Maybe this can be documented somewhere (or aboot-installer should
> print a message saying how to boot), or the machine configured to
> boot from disk automatically.

This is a frequent request; unfortunately, mapping Linux device names to SRM
device names seems to be somewhat intractable at present.

> In aboot, the default configs didn't work because they didn't have an
> console=ttySX option.  It seems that aboot-installer doesn't generate a
> config file at all but uses the standard from aboot (?).  If this is the
> case, this won't work with custom partitions... in any case,
> aboot-installer should realize that I did a serial console install and add
> appropriate entries.  FWIW, I managed to boot with:
>     aboot> b 2/vmlinuz ro initrd=/initrd.img root=/dev/sda3 console=ttyS0

Preserving console boot arguments and writing them to the aboot.conf would
probably be a good idea, yes.  The config file should *not* be the default
from aboot, there is certainly code to generate a config file that includes
the right partition information.  Did this happen in your case?

Steve Langasek
postmodern programmer

Attachment: signature.asc
Description: Digital signature

Reply to: