[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#271347: marked as done (needs aic79xx for Adaptec U320 SCSI)

Your message dated Mon, 13 Sep 2004 01:47:06 -0400
with message-id <E1C6jgA-0003A8-00@newraff.debian.org>
and subject line Bug#271347: fixed in discover1-data 1.2004.09.12
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 9 Sep 2004 10:32:29 +0000
>From philipps@espresto.com Thu Sep 09 03:32:29 2004
Return-path: <philipps@espresto.com>
Received: from mail.espresto.com [] 
	by spohr.debian.org with smtp (Exim 3.35 1 (Debian))
	id 1C5ME9-0002qX-00; Thu, 09 Sep 2004 03:32:29 -0700
Received: (qmail 8293 invoked from network); 9 Sep 2004 10:32:26 -0000
Received: from unknown (HELO espresto.com) (
  by mahakala.espresto.com with SMTP; 9 Sep 2004 10:32:26 -0000
Message-ID: <[🔎] 4140313A.1050005@espresto.com>
Date: Thu, 09 Sep 2004 12:32:26 +0200
From: Henri Philipps <philipps@espresto.com>
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040530 Debian/1.6-6.backports.org.1
X-Accept-Language: en
MIME-Version: 1.0
To: submit@bugs.debian.org
Subject: Package: installation-reports
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports

Debian-installer-version: RC1
uname -a: Linux radau 2.6.7-1-386 #1 Thu Jul 8 05:08:04 EDT 2004 i686 
Date: 2004/09/04 18:00
Method: Net-install from netinstall-cd, dhcp, using 
http://ftp.de.debian.org without proxy

Machine: SCSI Fileserver with Tyan Trinity GC-SL S2707 Board 
(Serverworks Chipset GC-SL), two SCSI disks, floppy, DVD-drive
Processor: P4 3.06 GHz HT
Memory: 4GB
Root Device: SCSI, sda2 (1GB)

Root Size/partition table:

Disk /dev/sda: 146.8 GB, 146815800320 bytes
255 heads, 63 sectors/track, 17849 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          24      192748+  83  Linux	(/boot)
/dev/sda2              25         146      979965   83  Linux	(/root)
/dev/sda3             147         389     1951897+  82  Linux swap
/dev/sda4             390       17849   140247450    f  W95 Ext'd (LBA)
/dev/sda5             390       17849   140247418+  fd  Linux raid 
autodetect	(created after installation for testing)

Output of lspci and lspci -n:

radau:/tmp# lspci
0000:00:00.0 Host bridge: ServerWorks GCNB-LE Host Bridge (rev 32)
0000:00:00.1 Host bridge: ServerWorks GCNB-LE Host Bridge
0000:00:07.0 VGA compatible controller: ATI Technologies Inc Rage XL 
(rev 27)
0000:00:08.0 Ethernet controller: Intel Corp. 82540EM Gigabit Ethernet 
Controller (rev 02)
0000:00:0f.0 ISA bridge: ServerWorks CSB5 South Bridge (rev 93)
0000:00:0f.1 IDE interface: ServerWorks CSB5 IDE Controller (rev 93)
0000:00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB Controller 
(rev 05)
0000:00:0f.3 Host bridge: ServerWorks CSB5 LPC bridge
0000:00:10.0 Host bridge: ServerWorks CIOB-X2 PCI-X I/O Bridge (rev 05)
0000:00:10.2 Host bridge: ServerWorks CIOB-X2 PCI-X I/O Bridge (rev 05)
0000:01:03.0 SCSI storage controller: Adaptec ASC-39320A U320 (rev 10)
0000:01:03.1 SCSI storage controller: Adaptec ASC-39320A U320 (rev 10)
0000:02:07.0 Ethernet controller: Intel Corp. 82545EM Gigabit Ethernet 
Controller (Copper) (rev 01)

radau:/tmp# lspci -n
0000:00:00.0 0600: 1166:0017 (rev 32)
0000:00:00.1 0600: 1166:0017
0000:00:07.0 0300: 1002:4752 (rev 27)
0000:00:08.0 0200: 8086:100e (rev 02)
0000:00:0f.0 0601: 1166:0201 (rev 93)
0000:00:0f.1 0101: 1166:0212 (rev 93)
0000:00:0f.2 0c03: 1166:0220 (rev 05)
0000:00:0f.3 0600: 1166:0225
0000:00:10.0 0600: 1166:0101 (rev 05)
0000:00:10.2 0600: 1166:0101 (rev 05)
0000:01:03.0 0100: 9005:8016 (rev 10)
0000:01:03.1 0100: 9005:8016 (rev 10)
0000:02:07.0 0200: 8086:100f (rev 01)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [O]
Reboot:                 [O]


The module for my SCSI-Controller (Adaptec ASC-39320A U320) wasn't 
loaded. I had to manually modprobe aic79xx; modprobe sd_mod to get 
partitioning working.

I tried to create a boot raid system (/ and /boot on raid1). When i was 
finished with all the partitioning i was told that boot-raid is not yet 
supported :-( Would be better to give this info at the beginning.

Then i tried to create a big logival volume on a raid1 device i created 
with the partitioner. But i had to manually create the volume group 
first (pvcreate /dev/md0; vgcreate vg /dev/md0) to use the partitioner 
for managing logical volumes (or i was to stupid to figure out how to do 
this with the partitioner).

Then it started the base-install but it stoped with an error message 
while setting up the the packages. I couldn't find the reason for this - 
there was some error message window under the error message window of 
the base-installer, so i couldn't read it. And i couldn't see a specific 
error message on console 3 (besides some warnings regarding mounting of 

I tried the above for several times with 2.6 and 2.4 kernel, but it was 
everytime the same.

Then i installed without raid and lvm and everything worked fine.

Creating a raid1 device and logical volumes on top of it by hand worked 
fine after the installation.

Besides my problems i really liked the installer. The ability to go back 
from every point was very helpful. And i think the curses based 
interface is optimal for the compromise between usability, flexibility 
and stability. The best thing for me was the ability to switch to the 
console and have all the tools i needed at hand. But i'm an experienced 
user/sysadmin. The normal desktop user might have some problems 
understanding the installer (but i don't care :-) ).

My biggest wish would be the possibility to create a boot-raid system 
(/boot and / on raid) with the installer.

Thanks for your great work!
Let me know, if i can give you more informations.

Henri Philipps

Systemadministration                                  EsPresto AG
philipps@espresto.com                           Breite Str. 30-31
Tel/Fax: +49.30.90 226.750/.760              10178 Berlin/Germany

Received: (at 271347-close) by bugs.debian.org; 13 Sep 2004 05:53:02 +0000
>From katie@ftp-master.debian.org Sun Sep 12 22:53:02 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1C6jlt-0006KR-00; Sun, 12 Sep 2004 22:53:01 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1C6jgA-0003A8-00; Mon, 13 Sep 2004 01:47:06 -0400
From: Joshua Kwan <joshk@triplehelix.org>
To: 271347-close@bugs.debian.org
X-Katie: $Revision: 1.51 $
Subject: Bug#271347: fixed in discover1-data 1.2004.09.12
Message-Id: <E1C6jgA-0003A8-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Mon, 13 Sep 2004 01:47:06 -0400
Delivered-To: 271347-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 3

Source: discover1-data
Source-Version: 1.2004.09.12

We believe that the bug you reported is fixed in the latest version of
discover1-data, which is due to be installed in the Debian FTP archive:

  to pool/main/d/discover1-data/discover1-data-udeb_1.2004.09.12_all.udeb
  to pool/main/d/discover1-data/discover1-data_1.2004.09.12.dsc
  to pool/main/d/discover1-data/discover1-data_1.2004.09.12.tar.gz
  to pool/main/d/discover1-data/discover1-data_1.2004.09.12_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 271347@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joshua Kwan <joshk@triplehelix.org> (supplier of updated discover1-data package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sun, 12 Sep 2004 22:21:29 -0700
Source: discover1-data
Binary: discover1-data discover1-data-udeb
Architecture: source all
Version: 1.2004.09.12
Distribution: unstable
Urgency: medium
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joshua Kwan <joshk@triplehelix.org>
 discover1-data - hardware lists for libdiscover1
 discover1-data-udeb - hardware lists for libdiscover1 (short list) (udeb)
Closes: 266947 267410 268434 269654 269734 271181 271214 271347
 discover1-data (1.2004.09.12) unstable; urgency=medium
   * Joshua Kwan
     - Fix pci.lst to reflect this from pci_ids.h:
          #define PCI_VENDOR_ID_3WARE             0x13C1
          #define PCI_DEVICE_ID_3WARE_9000        0x1002
       so 13c11002 now points to 3w-9xxx (which is currently only available
       in 2.6), closes: #269734
     - Change 10111014 to use the 'd4x5' driver. Closes: #269654
     - Change 104c8021 to bridge/ohci1394. Closes: #267410
     - Change 80861960 to unknown/unknown to fix a misload of the megaraid
       module. Closes: #271181
     - Add usb/usb-uhci for 8086265[8-b]. Closes: #268434
     - Add ethernet/e100 + appropriate names from pci.ids for 8086106[4-b].
       Closes: #266947
     - Add scsi/aic79xx for 90058016. Closes: #271347
     - Add ide/piix for 8086245b, 808624ca, 808624cb, 808624db.
       Closes: #271214
 c219e5ceea30df0bcc7b7c91a4a6cf0e 1433 libs optional discover1-data_1.2004.09.12.dsc
 76a500e33d349e5a8221c13e2de0dcbf 95001 libs optional discover1-data_1.2004.09.12.tar.gz
 815805d6812b452abbd4517860b5faa3 90878 libs optional discover1-data_1.2004.09.12_all.deb
 8066b348aa282c8e68b456fc10f62f8d 15410 debian-installer extra discover1-data-udeb_1.2004.09.12_all.udeb
package-type: udeb

Version: GnuPG v1.2.5 (GNU/Linux)
Comment: http://triplehelix.org/~joshk/pubkey_gpg.asc


Reply to: