[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#270176: RAID 1 problems in sarge RC1: Grub does not install

Package: installation-reports


Debian-installer-version: netinst-i386.iso RC-1 - 07
aug 2004 - I downloaded it from www.debian.org
uname -a: Linux servidor 2.6.7-1-386 #1 Thu Jul 8
05:08:04 EDT 2004 i686 GNU/Linux
Date: 01 sep 2004 at 8pm
Method: Installed from a CD

Machine: <Description of machine (eg, IBM Thinkpad
Processor: Intel Pentium III - 500 MHz
Memory: 256 MB RAM
Root Device: 2 * (IDE - Seagate 80GB - ST380021A)
Root Size/partition table: This is what I "asked" for,
but RAID 1 did not seem
to work, more comments afterwards...

/dev/md0       none            swap    sw             
0       0
/dev/md1       /               ext3   
defaults,errors=remount-ro 0       1
/dev/md2       /usr            ext3    defaults       
0       2
/dev/md3       /var            ext3    defaults       
0       2
/dev/md4       /home           ext3    defaults       
0       2
/dev/md5       /usr/local      ext3    defaults       
0       2
/dev/md6       /tmp            ext3    defaults       
0       2

Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] =
didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [ ]


    I am trying to install sarge on a RAID 1 System. I
had never done it before, but I did search as much
info as I could. I got info where it was said that you
could not install a RAID / or /boot partition, but at
the same time I saw some mails/workarounds written in
Bug report #251905.

    One of the last paragraphs there states:
    "Just tried these 2 patches on a fresh install
with a raid1 set and grub installed really nicely".

    This answer was written on June 21st, so I thought
this could have been fixed for sarge-RC1, and tried

    Everything works fine up to the point when it has
to install the boot loader. I get a warning: Debian
does not allow me to boot on a RAID device, but it
_allows_ me to go on, therefore I say i _want_ to keep
my RAID partitions.

    After some time, system warns: Grub could not be
installed on my system, if I persist on trying, I get
back to the "old style" installer, but even then I
can't install grub.

    I decided to switch to console, trying to make a
"manual" install, but system says that it cannot find
"grub", "grub-install", "update-grub", etc either in /
or /target. If I look for anything related to grub, I
can only see a file: /target/boot/grub/device.map. It
contains only two lines:

    (hd0) /dev/hda
    (hd1) /dev/hdc

    Any change to this file doesn't seem to make any
success: I tried to change /dev/hda for /dev/md1, as I
have / defined there with boot flag enabled, but there
was no success.

    I feel I am very close to the solution, but could
not get it, and I guess many other people could find
this problem while trying to install a RAID system
with the new sarge installer.

    I am willing to try this in the following days if
needed, as it will be much easier and helpful than
installing a "normal" system and "migrating" it to a
RAID system afterwards   :-)

    Apart from this, sarge-installer is awesome:
accurate and easy, great work!

    Sergio Ortiz

Install logs and other status info is available in
Once you have filled out this report, mail it to

Do you Yahoo!?
Win 1 of 4,000 free domain names from Yahoo! Enter now.

Reply to: