[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#265949: GRUB /dev/fd0 fails, solved by adding to device.map manually



Package: installation-reports

INSTALL REPORT

Debian-installer-version: 42729472 Aug 10 22:37 sarge-i386-businesscard-1.iso
uname -a: Linux desktop 2.4.26-1-k7 #1 Thu Jul 22 13:24:02 JST 2004 i686 GNU/Linux
Date: 15 aug 2004, 20:00
Method: network install, atapi CDROM, mirror debian.essentkabel.com, no proxy.
Machine: bits and pieces
Processor: AMD K7
Memory: 384MB
Root Device: IDE (maxtor) on /dev/hda7
Root Size/partition table:  
Disk /dev/hda: 30.7 GB, 30735581184 bytes
255 heads, 63 sectors/track, 3736 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         153     1228941    b  W95 FAT32
/dev/hda2             154        3736    28780447+   f  W95 Ext'd (LBA)
/dev/hda5   *         154         535     3068383+  83  Linux
/dev/hda6             536         596      489951   82  Linux swap
/dev/hda7             597        1123     4233096   83  Linux
/dev/hda8            1124        1378     2048256    c  W95 FAT32 (LBA)
/dev/hda9            1379        3225    14835996    b  W95 FAT32
/dev/hda10           3226        3378     1228941   1b  Hidden W95 FAT32
/dev/hda11           3379        3736     2875603+  83  Linux
This install uses /dev/hda6 (swap) and /dev/hda7 (root)

Output of lspci:
0000:00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] System Controller (rev 25)
0000:00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] AGP Bridge (rev 01)
0000:00:03.0 Network controller: Cologne Chip Designs GmbH ISDN network controller [HFC-PCI] (rev 02)
0000:00:04.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
0000:00:04.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
0000:00:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 15)
0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 06)
0000:00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 10)
0000:00:09.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
0000:01:05.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [ ]

Comments/Problems: GRUB fails to install on /dev/fd0 (same for (fd0) notation). 

- Syslog:
Aug 15 21:08:07 grub-installer: info: Installing grub on '/dev/fd0'
Aug 15 21:08:07 grub-installer: info: grub-install supports --no-floppy
Aug 15 21:08:07 grub-installer: info: Running chroot /target /sbin/grub-install --no-floppy "/dev/fd0"
Aug 15 21:08:07 grub-installer: error: Running 'grub-install --no-floppy "/dev/fd0"' failed.
Aug 15 21:08:09 main-menu[294]: WARNING **: Configuring 'grub-installer' failed with error code 1 
Aug 15 21:08:09 main-menu[294]: WARNING **: Menu item 'grub-installer' failed. 

- Executing grub-install from shell (chroot /target /sbin/grub-install /dev/fd0) gave:
/dev/fd0 does not have any corresponding BIOS drive.

- I booted an existing install on hda5 and mounted hda7, but same problem.

- Then changed device.map to include fd0 (workaround?)
  original /boot/grub/device.map:
(hd0)   /dev/hda
  changed /boot/grub/device.map:
(hd0)   /dev/hda
(fd0)   /dev/fd0

- This worked (/dev/hda7 mounted to /dock):
debian:/# chroot /dock /sbin/grub-install /dev/fd0
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

(hd0)   /dev/hda
(fd0)   /dev/fd0

- Reboot went fine.




Reply to: