[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241179: marked as done ([i386] [beta3] [netinst] successful install, no network in 2nd stage (pcmcia))

Your message dated Fri, 6 Aug 2004 01:58:11 +0200
with message-id <200408060158.16883.frederik@dannemare.net>
and subject line Processed: Bug#241179 (reassigned to netcfg)
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 31 Mar 2004 06:06:41 +0000
>From akkana@shallowsky.com Tue Mar 30 22:06:41 2004
Return-path: <akkana@shallowsky.com>
Received: from adsl-69-105-235-1.dsl.pltn13.pacbell.net (moon.timocharis.com) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B8Ys4-00025g-00; Tue, 30 Mar 2004 22:06:40 -0800
Received: by moon.timocharis.com (Postfix, from userid 666)
	id 510D719E9A; Tue, 30 Mar 2004 22:06:38 -0800 (PST)
Date: Tue, 30 Mar 2004 22:06:38 -0800
From: Akkana Peck <akkana@shallowsky.com>
To: submit@bugs.debian.org
Subject: Can't configure network on laptop with one pcmcia slot
Message-ID: <20040331060638.GA31075@shallowsky.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.3.28i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_30,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports

Debian-installer-version: beta3 netinst, with special pcmcia boot disc from joeyh
uname -a: Linux blackbird 2.4.25-1-386 #1 Tue Feb 24 08:11:13 EST 2004 i686 GNU/Linux
Date: Tue Mar 30 21:46:18 PST 2004
Method: boot from netinst CD

Machine: Sony Vaio SR-17
Processor: PIII 700MHz
Memory: 192M
Root Device: /dev/hda2 (20Mb internal IDE)
Root Size/partition table: 5.1G root, 90M /boot
Output of lspci: (available upon request, need to install another system to capture it)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


This laptop has one pcmcia slot: which means I can have the cdrom
plugged in, or the network card, but not both at once.

I found in a couple of tries that I had to select "other" for
networking, and skip the two networking steps, in order to install
the base system.  (I tried telling it what module to use, and I
tried unplugging the cdrom and plugging in the network card; both
confused or froze the installer.)

The base system installed, I rebooted with CD unplugged and network
card plugged in, and now no network was configured.  base-config
doesn't ask any networking questions, just says the system does not
seem to be connected to the internet.

I can't install packages from the CD, because it wants the wrong CD
name (apparently that's a known bug in beta3), but I can't install
from the network, or add security.debian.org to the sources list,
because it's convinced I have no network.

Could something be added to the installer stage after the first
reboot to ask again about a network?  (Or perhaps use hotplug on a
system that has pcmcia, but that may be a lot to ask from a minimal
base system.)  Failing that, could the initial base system install
have a category for "pcmcia network/configure later"?  Even if I
had to choose the network driver[s] manually, that would help as
long as it didn't complain if that hardware wasn't currently there.

Received: (at 241179-done) by bugs.debian.org; 5 Aug 2004 23:56:34 +0000
>From frederik@dannemare.net Thu Aug 05 16:56:34 2004
Return-path: <frederik@dannemare.net>
Received: from cpe.atm0-0-0-2421032.0x3ef2dbfa.arcnxx7.customer.tele.dk (host.kl-teknik.com) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Bss66-0003BE-00; Thu, 05 Aug 2004 16:56:34 -0700
Received: from mail.thepenguininvasion.dk (0x5358aaae.abnxx12.adsl-dhcp.tele.dk [::ffff:])
  (AUTH: PLAIN admin@sentinel.dk)
  by host.kl-teknik.com with esmtp; Fri, 06 Aug 2004 02:01:43 +0200
  id 000230FF.4112CA68.00002C78
From: Frederik Dannemare <frederik@dannemare.net>
To: 241179-done@bugs.debian.org
Subject: Processed: Bug#241179 (reassigned to netcfg)
Date: Fri, 6 Aug 2004 01:58:11 +0200
User-Agent: KMail/1.6.2
MIME-Version: 1.0
Content-Disposition: inline
Content-Type: Text/Plain;
Content-Transfer-Encoding: quoted-printable
Message-Id: <200408060158.16883.frederik@dannemare.net>
Delivered-To: 241179-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-1.4 required=4.0 tests=BAYES_00,UPPERCASE_25_50 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Hash: SHA1

=2D --=20
=46rederik Dannemare | mailto:frederik@dannemare.net
GnuPG key: search for 'dannemare' on http://pgpkeys.mit.edu
Key fingerprint: BB7B 078A 0DBF 7663 180A  F84A 2D25 FAD5 9C4E B5A8
http://frederik.dannemare.net | http://www.linuxworlddomination.dk
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: