[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241179: successful install, no network in 2nd stage (pcmcia)

Hash: SHA1

On Thursday 05 August 2004 03:04, Akkana Peck wrote:
> Frederik Dannemare writes:
> > > this where I was supposed to install wireless-tools, or did you
> > > mean later, after the reboot?  In any case, I'm using a wired
> > > network for this, so wireless-tools shouldn't matter yet).
> >
> > No. You did everything just right so far. Install wireless-tools
> > when you have finished both 1st and 2nd stage of the installation
> > (ie. when the installation is 100% completed and you get at login
> > prompt).
> >
> > > After the reboot, it went through the time setting, then said
> > > "You don't seem to be connected to the internet" and when I gave
> > > it http and ftp.debian.org
> >
> > Remember: at this point you haven't yet installed wireless-tools.
> > Thus, your wireless NIC doesn't work just yet, so skip downloading
> > any packages at this point.
> I don't understand where wireless-tools comes in.  I'll repeat,
> I am not using a wireless network.  I'm using a normal wired one,
> with a 3Com 3c59x card.  Are you saying wireless-tools is needed
> even for a network that's not wireless?

No, the package is not needed for wired cards, but I assumed that you 
wanted to use your wireless card as your primary NIC during the 
installation, since the installer only handles the setup of one NIC.

And since your very first mail was about wireless pcmcia not working (no 
mention of a second (3com) card), I have focused only on getting your 
wireless to work - not even thinking about your wired card, since (as 
mentioned) the installer doesn't handle setting up more than one card 
during the installation, anyways.

Hence, my howto/work-around was targeted for situations where the user 
has a CD-ROM and (wireless) NIC only accessible via a single pcmcia 
slot in the computer.

> > > (are those two mutually exclusive?
> > > anyway, I tried ftp as well as http)
> >
> > I'm not 100% sure what you mean here, but you can certainly have
> > both http and ftp sources to download from in your
> > /etc/apt/sources.list
> The sequence of screens in the second stage of the installer is:
> - Pick a protocol (http, ftp, cdrom, plus a couple others I don't
>   remember).  It only seems to take one; I tried it once with
>   http, then I tried it with ftp.
> - Pick a country (I'm in the US)
> - Pick a mirror site for that country.  (I'm picking ftp.debian.org,
>   and I wasn't clear whether it was kosher to use that mirror even
>   if I picked http rather than ftp two screens earlier. But it
>   doesn't matter since it's pretty clear I don't have a network
>   at all.)
> > As mentioned above: skip downloading stuff at this point, and just
> > finish up this 2nd stage of the installer. When 2nd stage has
> > finished and you get the login prompt, you should login as root and
> > install the wireless-tools. Finally, do: 'idfown <iface> && ifup
> > <iface>'. This should get your wirelesss NIC going. At this point
> > you can choose 'apt-setup' to add ftp and/or http sources to
> > download new packages from.
> Okay, I did that, skipped installing new packages (I hit cancel)
> and went straight to "finish configuring the installer" (I also
> skipped configuring the MTA).  I got a login prompt, so I logged
> in, and typed ifconfig, and as expected, I only have lo, no eth0
> (because it still doesn't see the network card).
> I tried modprobe 3c59x as root, but I got:
> modprobe: Can't open dependencies file
> /lib/modules/2.4.18-bf2.4/modules.dep (no such file or directory)

I don't get that. I'm really no expoert in d-i internals, and 
2.4.18-bf2.4 sounds to me like a kernel from good old woody. Still, 
let's focus on my initial attempt which is to get wireless working 
(disregaring the fact that you have a wired card also)

Looking over the whole situation again, I would suggest you to try again 
exactly like this (where you install wireless-tools just before 
finishing 1st stage):

 ( I have just tried it on two different laptops here,  
    and it works beautifully... ) 

Boot the installer with the CD-ROM device plugged into the PCMCIA slot 
and do a normal 1st stage installation, except that you should skip 
network setup or just type in dummy values at this point.

Then when it says "Installation complete", choose 'Go back' to drop back 
to the main menu. Now change the PCMCIA device from CD-ROM to NIC, and 
choose to 'Detect network hardware'. Your wireless NIC should now be 
detected and you can continue (again 'Go back' to main menu) to 
'Network configuration'.

After having configured the wireless NIC, press Alt+F2 to get a shell. 
Change the PCMCIA device from NIC to CD-ROM and type in the shell:
 chroot /target
 mount /cdrom
 apt-get install wireless-tools
 umount /cdrom
Go back to Alt+F1 and change the PCMCIA device from CD-ROM to NIC.

Choose 'Continue' to reboot and thereby finishing the 1st stage of the 
installation process.

When 2st stage comes up after the reboot, you should have a working 
wireless NIC and as such you can choose to download extra packages via 
ftp, http, etc.


> ifdown and ifup aren't going to help if ifconfig doesn't show the
> interface existing at all, right?

Yes, if ifconfig doesn't list the interface upon a finished install, you 
can assume it is because the interface is not listed 
in /etc/network/interfaces, and as such ifup/ifdown will also not work 
for the interface.

I forget if you have already mentioned this earlier on, but have you 
actually had the wireless card in question working in Linux at anytime?
- -- 
Frederik Dannemare | mailto:frederik@dannemare.net
GnuPG key: search for 'dannemare' on http://pgpkeys.mit.edu
Key fingerprint: BB7B 078A 0DBF 7663 180A  F84A 2D25 FAD5 9C4E B5A8
http://frederik.dannemare.net | http://www.linuxworlddomination.dk
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: