[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241179: successful install, no network in 2nd stage (pcmcia)

Hash: SHA1

On Thursday 05 August 2004 05:42, Akkana Peck wrote:
> Frederik Dannemare writes:
> > No, the package is not needed for wired cards, but I assumed that
> > you wanted to use your wireless card as your primary NIC during the
> > installation, since the installer only handles the setup of one
> > NIC.
> >
> > And since your very first mail was about wireless pcmcia not
> > working (no mention of a second (3com) card), I have focused only
> > on getting your
> I'm not sure why you say that.  I looked back over the bug and I
> don't see anywhere I mention wireless, and I've never been using
> wireless, always this 3com ethernet (wired) card.  It's not the
> second card, it's the only card (I do own a wireless card, but
> have never been using it during this install scenario).

Argh. Sorry, I was mixing up your report with another one that looks 
like like it (I have been processing so many reports lately) but that 
other one is wireless.

> If I said something somewhere to imply otherwise, it was an error
> (where was that?)

My fault.

> > Hence, my howto/work-around was targeted for situations where the
> > user has a CD-ROM and (wireless) NIC only accessible via a single
> > pcmcia slot in the computer.
> I think I followed it except for the wireless-tools part.


> > I don't get that. I'm really no expoert in d-i internals, and
> > 2.4.18-bf2.4 sounds to me like a kernel from good old woody. Still,
> Yes, you're right.  Ignore the 2.4.18 stuff, that was booting off
> the wrong kernel.  (This testing is complicated by the fact that
> the installer doesn't seem willing to re-use my existing /boot,
> so I have to go through three screens until grub fails, then boot
> into the working system and copy files by hand into /boot, then
> reboot into the stage 2 installer.  I was using the wrong kernel
> that time.  Please ignore anything I said about modprobe errors.)

will do

> With the correct kernel, 2.4.26-1-386, it does start pcmcia (and
> probably hotplug, though I missed seeing the messages for that)
> and I do see an eth0 device with ifconfig -a, but it has no IP
> address.  (I set a static IP address, netmask, gateway, and
> nameservers during stage 1 after I disconnected the cdrom and
> connected the ethernet card.)
> However, if I ctrl-alt-f2 to get a shell while the stage 2 installer
> is still running, log in as root, and run ifup eth0, then it sees
> the network and I can proceed with installation.
> Why doesn't it run ifup when the stage 2 installer boots?
> Might there be a sequence problem, with the network being
> initialized before pcmcia/cardbus?  (I'm booting with the card
> still inserted from the stage1 network config step, not trying
> to hotplug it after booting.)
> > let's focus on my initial attempt which is to get wireless working
> > (disregaring the fact that you have a wired card also)

disregard this :) I'm so sorry to have tried to mislead you.

> Wireless ads two extra device swaps, and I'd have to specify an
> essid at some point during the process (does the sarge installer
> handle that, 

yes, the installer can handle stup of essid (and wep, btw).

> or would I have to ctl-alt-F2 and run iwconfig by 
> hand?), so I'm hoping it's okay if I keep testing with the wired
> card.

no problem. you do that.

> One other difference is that my wireless card is pcmcia while my
> ethernet card is cardbus, so if there's a problem with cardbus
> initialization during stage 2, the wireless card may not point that
> out.  Most modern cards are cardbus.
> [ description of new workaround for stage 1 ]
> > When 2st stage comes up after the reboot, you should have a working
> > wireless NIC and as such you can choose to download extra packages
> > via ftp, http, etc.
> Nope, that part still doesn't work.


> It looks like we're down to two problems:
> 1. No provision during stage 1 for saying "I really have a network
>    even though the card isn't plugged in."  Your workaround seems
>    to work (probably including the extra parts with wireless-tools,
>    for those using a wireless card).
> 2. Stage 2 does not initialize the network when it's running off
>    a cardbus card.  The ctrl-alt-F2, log in, ifup, ctrl-alt-F1
>    workaround seems to solve this.

How about consecutive reboots when the system is installed via the sarge 
installer and up'n'running? Is the network then also not initialized so 
that you have to always do ifup manually upon every reboot?

> > I forget if you have already mentioned this earlier on, but have
> > you actually had the wireless card in question working in Linux at
> > anytime?
> The 3Com card I'm using works fine on my working sarge (installed
> using the woody installer, then upgrading; it also works on libranet,
> xandros and various redhats).
> I have had some issues with some versions of debian when hotplugging
> the card, because the hotplug scripts reference $INTERFACE$LIFACE,
> where $LIFACE is the string "=hotplug", and causes ifup to fail to
> see the card (removing the $LIFACE fixed the problem).  I have not
> tried this during this installer test, since editing hotplug scripts
> is harder than running ifup by hand and I'm not trying to hotplug
> the card anyway.  

> I figure it's a bug either way if the installer 
> can't see a cardbus card using the scripts it installed itself.


> My wireless card (which I have not yet been using in this install)
> works if I write a script to make ifup set the essid (since it's
> pcmcia it doesn't run into the $LIFACE hotplug problem).
> I'll run a test using a pcmcia ethernet card and report back.

Thanks. I really appreciate all the time and offert you have put into 
testing this matter.
- -- 
Frederik Dannemare | mailto:frederik@dannemare.net
GnuPG key: search for 'dannemare' on http://pgpkeys.mit.edu
Key fingerprint: BB7B 078A 0DBF 7663 180A  F84A 2D25 FAD5 9C4E B5A8
http://frederik.dannemare.net | http://www.linuxworlddomination.dk
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: