[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241179: successful install, no network in 2nd stage (pcmcia)

Hash: SHA1

On Wednesday 04 August 2004 21:42, Akkana Peck wrote:
> Frederik Dannemare writes:
> > One more thing: You'll have to 'apt-get install wireless-tools'
> > from the CD after you have finished to whole installation.
> >
> > I can confirm that this works on my laptop with PCMCIA NIC, if I
> > don't plugin my PCMCIA NIC until 1st stage says "Installation
> > complete", and then 'go back' to main menu to detect/reconfigure
> > networking. It worked, but wireless-tools had to be installed
> > afterwards, manually.
> It didn't work for me.  I unplugged the cdrom after it ejected,
> plugged in the ethernet card, said "go back" and arrowed up to
> "detect network hardware".  It detected my network card (3c59x)
> just fine, then dumped me back into the end-of-installation
> sequence.  So I said "go back" again and went through "configure
> networking" and gave it my IP, netmask, DNS etc.  It dumped me
> back into the end sequence, so this time I let it reboot (was
> this where I was supposed to install wireless-tools, or did you
> mean later, after the reboot?  In any case, I'm using a wired
> network for this, so wireless-tools shouldn't matter yet).

No. You did everything just right so far. Install wireless-tools when 
you have finished both 1st and 2nd stage of the installation (ie. when 
the installation is 100% completed and you get at login prompt).

> After the reboot, it went through the time setting, then said
> "You don't seem to be connected to the internet" and when I gave
> it http and ftp.debian.org 

Remember: at this point you haven't yet installed wireless-tools. Thus, 
your wireless NIC doesn't work just yet, so skip downloading any 
packages at this point.

> (are those two mutually exclusive? 
> anyway, I tried ftp as well as http) 

I'm not 100% sure what you mean here, but you can certainly have both 
http and ftp sources to download from in your /etc/apt/sources.list

> and got "Failed to access the 
> Debian archive".

As mentioned above: skip downloading stuff at this point, and just 
finish up this 2nd stage of the installer. When 2nd stage has finished 
and you get the login prompt, you should login as root and install the 
wireless-tools. Finally, do: 'idfown <iface> && ifup <iface>'. This 
should get your wirelesss NIC going. At this point you can choose 
'apt-setup' to add ftp and/or http sources to download new packages 

> I tried unplugging the card, then plugging it back in (I had
> initially just left the card in while booting) but I didn't get
> a beep (I did get a beep when I plugged it in earlier, when I was
> running off the installer kernel; but I don't get a beep when I plug
> it in to my normal installed sarge running 2.4.26, because it's
> cardbus, not pcmcia, so it calls hotplug instead of pcmcia, which
> doesn't beep.)
> If I go into ctl-alt-F2 at this point and run dmesg, there are no
> messages indicating it saw any pcmcia events or loaded the driver
> for the network card.  If I do dmesg | grep -i pcmcia I see nothing;
> same for dmesg | grep -i hotplug.  So it looks like it's not
> running any pcmcia/cardbus services which would enable it to
> see the card.

I don't think grep'ing for hotplug or pcmcia necessarily shows anything 
(at least it does not for me). However, you should see some lines which 
mention that a driver has been loaded, and you should see a few lines 
with the interface name (e.g. eth1).
- -- 
Frederik Dannemare | mailto:frederik@dannemare.net
GnuPG key: search for 'dannemare' on http://pgpkeys.mit.edu
Key fingerprint: BB7B 078A 0DBF 7663 180A  F84A 2D25 FAD5 9C4E B5A8
http://frederik.dannemare.net | http://www.linuxworlddomination.dk
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: