[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#240842: marked as done ([i386] [beta3] [netinst] pcmcia network config failed)

Your message dated Sun, 1 Aug 2004 13:55:41 +0200
with message-id <200408011355.46960.frederik@dannemare.net>
and subject line Bug#240842: pcmcia network config failed
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 29 Mar 2004 15:18:35 +0000
>From kgrossjo@eu.uu.net Mon Mar 29 07:18:35 2004
Return-path: <kgrossjo@eu.uu.net>
Received: from emr0.eu.uu.net [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B7yX4-0000jF-00; Mon, 29 Mar 2004 07:18:35 -0800
Received: from imr1.eu.uu.net ([])
	by emr0.eu.uu.net with esmtp id 1B7wNY-0003Nx-O5
	for submit@bugs.debian.org; Mon, 29 Mar 2004 13:00:36 +0000
Received: from localhost ([])
	by imr1.eu.uu.net with esmtp id 1B7wNY-000509-Ev
	for submit@bugs.debian.org; Mon, 29 Mar 2004 13:00:36 +0000
Received: from agen1.ams.ops.eu.uu.net ([] helo=amr.eu.uu.net)
	by imr1.eu.uu.net with esmtp id 1B7wNX-000504-Vu
	for submit@bugs.debian.org; Mon, 29 Mar 2004 13:00:35 +0000
Received: from rumba.mci.com (dhcp-68.de.uu.net [] (may be forged))
	by amr.eu.uu.net (8.12.10/8.12.10) with ESMTP id i2TD0Zsm022481
	for <submit@bugs.debian.org>; Mon, 29 Mar 2004 13:00:35 GMT
	SSL encryption with TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256
	SMTP AUTH used user=kgrossjo AuthMechanisms=LOGIN
	(envelope-from kgrossjo@eu.uu.net)
To: submit@bugs.debian.org
Subject: Sarge i386 netinst can't configure PCMCIA network card
From: Kai Grossjohann <kgrossjo@eu.uu.net>
Date: Mon, 29 Mar 2004 15:00:34 +0200
Message-ID: <86smfrkdu5.fsf@eu.uu.net>
User-Agent: Gnus/5.110002 (No Gnus v0.2) Emacs/21.3.50 (gnu/linux)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Package: installation-reports

Debian-installer-version: http://gluck.debian.org/cdimage/testing/sarge_d-i/i386/beta3/sarge-i386-netinst.iso
uname -a: Linux rumba 2.4.25-1-686 #1 Tue Feb 24 10:55:59 EST 2004 i686 GNU/Linux
Date: 2004-03-29, 10:00 UTC
Method: Boot from above mentioned ISO image

Machine: IBM Thinkpad 600E with xirc2ps_cs network card
Processor: Mobile Pentium II, 400 MHz
Memory: 288884 kB
Root Device: TOSHIBA CD-ROM XM-1902B on /dev/hdc
Root Size/partition table: 
        Filesystem            Size  Used Avail Use% Mounted on
        /dev/hda1             4.2G  2.0G  2.1G  49% /
        tmpfs                 142M     0  142M   0% /dev/shm
        /dev/hda3             4.7G  2.4G  2.1G  54% /home

Output of lspci:

pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:02.0 CardBus bridge: Texas Instruments PCI1251A
0000:00:02.1 CardBus bridge: Texas Instruments PCI1251A
0000:00:06.0 Multimedia audio controller: Cirrus Logic CS 4610/11 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
0000:00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:01:00.0 VGA compatible controller: Neomagic Corporation NM2200 [MagicGraph 256AV] (rev 20)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


The problem was that it couldn't configure the network.  Going into a
shell showed that cardmgr would say "no sockets found!", like this:

    Mar 26 17:22:18 rumba cardmgr[836]: starting, version is 3.1.33
    Mar 26 17:22:19 rumba cardmgr[836]: no sockets found!
    Mar 26 17:22:19 rumba cardmgr[836]: exiting

Originally, I thought it was the wrong kernel module.  I tried many
things, most of which I've forgotten now.  But then, I managed to
upgrade the whole system to unstable, and that did it.  I /think/ it
was the upgrade of pcmcia-cs to 3.2.5-2.5, but of course I'm not sure
whether it was this package or perhaps another package.

I'm reluctant to wipe the installation to try again, with just the
newer pcmcia-cs.  (This is my main machine that I need to work on
every day.)  But if you make a new image with the more recent
pcmcia-cs included, then I can try to boot it to see if that fixes
the problem.

I hope I managed to describe this well enough.  In the best luser
manner, I managed not to keep track of what I did.  Maybe I can
convince myself to try another install, now that I know how to fix


Received: (at 240842-done) by bugs.debian.org; 1 Aug 2004 11:54:30 +0000
>From frederik@dannemare.net Sun Aug 01 04:54:30 2004
Return-path: <frederik@dannemare.net>
Received: from cpe.atm0-0-0-2421032.0x3ef2dbfa.arcnxx7.customer.tele.dk (host.kl-teknik.com) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BrEv8-0005oo-00; Sun, 01 Aug 2004 04:54:30 -0700
Received: from mail.thepenguininvasion.dk (0x5358aaae.abnxx12.adsl-dhcp.tele.dk [::ffff:])
  (AUTH: PLAIN admin@sentinel.dk)
  by host.kl-teknik.com with esmtp; Sun, 01 Aug 2004 13:59:35 +0200
  id 00003F13.410CDB27.00005225
From: Frederik Dannemare <frederik@dannemare.net>
To: Kai Grossjohann <kgrossjo@eu.uu.net>, 240842-done@bugs.debian.org
Subject: Re: Bug#240842: pcmcia network config failed
Date: Sun, 1 Aug 2004 13:55:41 +0200
User-Agent: KMail/1.6.2
References: <200407270001.37277.frederik@dannemare.net> <86brhwc562.fsf@ketchup.de.uu.net>
In-Reply-To: <86brhwc562.fsf@ketchup.de.uu.net>
MIME-Version: 1.0
Content-Disposition: inline
Content-Type: Text/Plain;
Content-Transfer-Encoding: quoted-printable
Message-Id: <200408011355.46960.frederik@dannemare.net>
Delivered-To: 240842-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Hash: SHA1

On Saturday 31 July 2004 22:06, Kai Grossjohann wrote:
> Frederik Dannemare <frederik@dannemare.net> writes:
> > Much has changed with the installer since March, and I believe the
> > pcmcia issue you mention has been dealt with since then, so I would
> > very much appreciate it, if you could find time to download and
> > test the latest[1] cd image and let me know if the problem is gone.
> I'm afraid that it is not easy for me to repeat this; I now have
> different hardware (IBM R40) with a built-in network card.

Okay, thank you for the feedback. I'll allow myself to close this one=20
then, based on the fact that you got it working when you afterwards=20
upgraded your installation to unstable. Also, I can confirm pcmcia=20
networking working on two different laptops using the current=20
=2D --=20
=46rederik Dannemare | mailto:frederik@dannemare.net
GnuPG key: search for 'dannemare' on http://pgpkeys.mit.edu
Key fingerprint: BB7B 078A 0DBF 7663 180A  F84A 2D25 FAD5 9C4E B5A8
http://frederik.dannemare.net | http://www.linuxworlddomination.dk
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: