[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#261460: Is anyone else seeing this? -- Re: Bug#261460: Non-DHCP network config step of d-i is broken

On Thursday, July 29, 2004, at 05:42 AM, Rick Thomas wrote:

On Wednesday, July 28, 2004, at 04:27 PM, Joshua Kwan wrote:

On Wed, Jul 28, 2004 at 03:40:30PM -0400, Rick Thomas wrote:
Please, somebody, give it a try and let me know I'm not going
crazy.  It doesn't take very long to get to the point where this
bug manifests itself, and you don't ever get to the point where you
need to touch your hard disk, so it's easy to check.

I'm inclined to believe that this is a corner case we haven't handled,
and maybe it only applies on powerpc. Because I can't reproduce it for
the life of me.

If you configure your network device manually, does it work?

If so, boot with DEBCONF_DEBUG=5, stick a pscp binary somewhere, wget it once you've manually configured the network, and put /var/log/syslog and
/var/log/messages somewhere I can see them.

Thanks, and sorry for not getting to this bug earlier.

Joshua Kwan

Well... here's an interesting observation!

My gateway is at a different address from my DNSserver.

(For what it's worth: Gateway=, DNSserver=

I noticed that the non-DHCP network configuration step always offers to set the DNSserver to the same address the gateway. And I always change it to point to my DNSserver.

But this time I tried (out of desperation -- just trying random stuff) leaving the DNSserver the same as the gateway.

And it worked! It did *not* loop back to the network configuration step.

Is this a clue? What log files (or whatever else) do you need to see to followup on this?

Would somebody please try this out on an i386? (DNSserver address != Gateway address) And let me know if it breaks non-DHCP network configuration?

As I say, It's easy to try... you never need to get to the point of touching the disks.



Reply to: