[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#254919: (no subject)



Package: installation-reports
Severity: wishlist

INSTALL REPORT

Debian-installer-version: sid image, 20040616
uname -a: <install within bochs>
Date: all day, 17 June 2004
Method: Boot off the CD image.

Machine: bochs 2.11-5
Processor: bochs
Memory: 128Mb
Root Device: hda image
Root Size/partition table: 500Mb
Output of lspci and lspci -n:
not yet installed. also, probably irrelevant.

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [ ]

Comments/Problems:

A couple of questions and suggestions, all in expert mode:

1. When the installer tried to detect network hardware, it asks for
   modules to load. The list displays the modules as "matching your
   hardware". The list includes all kindes of ancient and current
   IDE chipsets but nothing related to networking (because d-i fails
   to detect bochs' ne2000 (ne.o) card. In VMWare, pcnet.o is
   correctly found.). This can be potentially confusing to the user.

   http://people.debian.org/~madduck/d-i/screenshots/21-net-select.png

   Also, none of the chipsets are present on the machine, and yet
   the installer reports them all as "matching my hardware".
   I understand that chipsets aren't easy to detect, but maybe it
   shouldn't say that it presents matching ones. More like: the
   following cannot be automatically detected. Please choose from
   the list any drivers that correspond to your hardware.

   Also, it then complains that some modules (ide-scsi, ide-mod,
   ide-scsi-mod, ide-generic, ide-floppy) are unavailable. Well,
   they weren't previously, and I am installing networking hardware,
   not IDE stuff.

   The same applies to the detection of general hardware. Only IDE
   chipsets are shown. Nothing else.

   NOTE: this seems to have been fixed in the netboot image from
   joeyh's p.d.o page, downloaded on 20040617, but it still suggests
   floppy.o when scanning for network interfaces.

2. I selected the ppp component, but I can't find any notion of PPP
   setup anywhere. Also, PPPoE is not available.

3. If XFS is used as the root (or /boot) filesystem, a warning is
   displayed wrt Grub. I am using both together for a while now and
   never had any problems. Maybe you want to tone down the warning
   a little... Or just remove it alltogether. YMMV.

4. When grub installs, it displays a notice that it may take a long
   time in text mode. I think this should also be displayed by d-i
   so as to not confuse users.

5. Grub actually doesn't install. It hangs at 50% of 'grub-install
   (hd0)'. The console says it's probing BIOS drives. And it has
   been for 20 minutes...

   NOTE: This seems to be related to XFS and is a known bug in Grub.
   Killing grub-install from the console and restarting it from the
   menu does the trick.

   Maybe a sync before grub-install would solve the problem?

6. Running base-config from within the installer and configuring the
   timezone yields an error:
     /usr/sbin/tzsetup requires an argument -- c

7. When run after reboot, I would have expected the timezone to be
   pre-selected given my regional selection. But it wasn't...

8. I am no LVM expert at all, but I installed twice in a row,
   zeroing the partition table, and yet, the VGs and LVs were still
   known -- i could not define new VGs and LVs with the same names.

9. running base-config from the installer is somewhat weird. If
   scrolling back up, the selection bar becomes transparent, ctrl-l
   will redraw it.

   Also, I need to finish the install twice before it messes up the
   screen, writes rebooting in a chaotic way, and then reboots.

All that said, you guys have done a great job.

-- 
Please do not CC me when replying to lists; I read them!
 
 .''`.     martin f. krafft <madduck@debian.org>
: :'  :    proud Debian developer, admin, and user
`. `'`
  `-  Debian - when you have better things to do than fixing a system
 
Invalid/expired PGP subkeys? Use subkeys.pgp.net as keyserver!

Attachment: signature.asc
Description: Digital signature


Reply to: