[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#252995: (no subject)

Package: installation-reports


Debian-installer-version: nightly-build 20040527
	(parts rechecked with 20040603)
uname -a: Linux carrington 2.6.5-1-386 #2 Fri Apr 30 20:13:30 EST 2004 i686 GNU/Linux
Date: 29/05/2004
Method: netboot-cd using linux26

Machine: Homebrew based on an Asus K8V SE deluxe mobo
Processor: AMD Athlon 64 3200+
Memory: 512 MiB
Root Device: S-ATA /dev/hde
Root Size/partition table:
  hde1   boot   primary   NTFS         40G
  hde3          primary   Linux ext3   20G   /
  hde5   NC     logical   Linux LVM   125G

hde5 is divided into:
swap    4G
opt    10G
mp3    60G
home   the rest

Output of lspci and lspci -n:

0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host
Bridge (rev 01)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800
South]0000:00:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394
Host Controller (rev 80)
0000:00:08.0 RAID bus controller: Promise Technology, Inc. PDC20378
(SATA150 TX) (rev 02)
0000:00:0a.0 Ethernet controller: Marvell Yukon Gigabit Ethernet
10/100/1000Base-T Adapter (rev 13)
0000:00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA
RAID Controller (rev 80)
0000:00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
0000:00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 81)
0000:00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800
South]0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G650 AGP
(rev 02)

0000:00:00.0 Class 0600: 1106:3188 (rev 01)
0000:00:01.0 Class 0604: 1106:b188
0000:00:07.0 Class 0c00: 1106:3044 (rev 80)
0000:00:08.0 Class 0104: 105a:3373 (rev 02)
0000:00:0a.0 Class 0200: 11ab:4320 (rev 13)
0000:00:0f.0 Class 0104: 1106:3149 (rev 80)
0000:00:0f.1 Class 0101: 1106:0571 (rev 06)
0000:00:10.0 Class 0c03: 1106:3038 (rev 81)
0000:00:10.1 Class 0c03: 1106:3038 (rev 81)
0000:00:10.2 Class 0c03: 1106:3038 (rev 81)
0000:00:10.3 Class 0c03: 1106:3038 (rev 81)
0000:00:10.4 Class 0c03: 1106:3104 (rev 86)
0000:00:11.0 Class 0601: 1106:3227
0000:00:11.5 Class 0401: 1106:3059 (rev 60)
0000:00:18.0 Class 0600: 1022:1100
0000:00:18.1 Class 0600: 1022:1101
0000:00:18.2 Class 0600: 1022:1102
0000:00:18.3 Class 0600: 1022:1103
0000:01:00.0 Class 0300: 102b:2537 (rev 02)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Initially I tried the default boot, but my harddisk was not found. I
guess this is due to my mobos s-ata chipset not supported by Linux 2.4,
booting with linux26 solved this problem.
Build 20040603 had this too. I checked the expert-install and handprobed
all ide-drivers. Didn't work either.
Maybe kernel 2.4.27 (rc2 had some sata-related fixes I read) will fix
this, but I haven't tried that yet.

Partitioning the harddisk also had some gotchas. I tried to use JFS for
the root, but after waiting some 15 minutes to have that 20G formatted I
killed the process. I couldn't see any progress for it nor did any of the
consoles show any errormessages.
I later read on debian-boot that it was a known bug and fixed. Didn't
check with 20040603 if it was fixed there.

I couldn't get a root on LVM with XFS to work, but after reading about it
on debian-boot and someone saying something of the likes that root on LVM
doesn't work and other people claimed XFS on root also has a few problems
(notably: you have to install lilo instead of grub) I decided to work
around that by using a seperate root partition formatted with ext3.
On build 20040603 both problems were caught and shown in a warning.

The last problem I encountered with 20040529 (but couldn't confirm with
20040603) was that the homedir of the user I created wasn't created on the
logical volume home. I had to correct this by hand.

Further installation went ok.


	"Only two things are infinite, the universe and human stupidity,
	and I'm not sure about the former. "
	 -- Albert Einstein (1879-1955)

Reply to: