[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#252986: TC1 fails to detect IDE modules (expert26)

Package: installation-reports

Debian-installer-version: Test Candidate 1 Netinst (i386) (2004-05-30) from
uname -a: N/A
Date: 2004-06-06
Method: 'expert26' installation from CD.
Machine: Generic with Asus A7M266 motherboard
Processor: AMD Athlon 1,3GHz
Memory: 256MB
Root Device: hda, 200GB Seagate Barracuda 7200.7 (IDE)
Root Size/partition table:

Disk /dev/hda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
   /dev/hda1   *           1           8       64228+  83  Linux
   /dev/hda2               9          70      498015   83  Linux
   /dev/hda3              71       24321   194796157+  83  Linux

(/boot, swap, then /)

Output of lspci:

0000:00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P]
System Controller (rev 13)
0000:00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] AGP Bridge
0000:00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South]
(rev 40)
0000:00:04.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:04.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 16)
0000:00:04.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1
Controller (rev 16)
0000:00:04.4 Non-VGA unclassified device: VIA Technologies, Inc. VT82C686
[Apollo Super ACPI] (rev 40)
0000:00:05.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
0000:00:0a.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
0000:00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
0000:00:0d.1 Input device controller: Creative Labs SB Live! MIDI/Game Port
(rev 07)
0000:01:05.0 VGA compatible controller: nVidia Corporation NV20 [GeForce3]
(rev a3)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [0]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


As I use expert26 I detect hardware in stages. With Test Candidate 1 the
installer was unable to detect ide-scsi, ide-mod, ide-probe-mod,
ide-detect and ide-floppy. This worked with beta4 (with expert26).

During the base-install, after I chose to install the 2.6.6 Linux kernel, the
installer told me a step had gone wrong (no more details, sorry).


I have given beta4 a few twirls and now the Test Candidate 1. It would be nice
to have an option to NOT install 'discover' and 'hotplug' for 2.6 kernel
installs. I've had discover automatically load OSS sound drivers, thus grabing
the sound device, which interfers with ALSA. At some point hotplug would also
load OSS, but that has been fixed recently by blacklisting OSS drivers.

After the installation I apt-get remove discover1 and hotplug, then alsaconf
can load the ALSA drivers for my sound device without problems. As for the
rest of the hardware I use modconf.

Reply to: