[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#247218: installation-reports: Success on PowerBook G4 alu 17" (but problems with yaboot and spanish keyboard)



On Wed, May 05, 2004 at 05:30:38PM +0200, Gaudenz Steinlin wrote:
> clone 247218 -1
> reassign -1 yaboot-installer
> retitle -1 append "video=ofonly" to yaboot.conf if started with install-safe
> clone 247218 -2
> reassign -2 kbd-chooser
> retitle -2 wrong keymap for spanish powermac
> Thanks
> 
> On Mon, May 03, 2004 at 11:06:05PM +0200, Luis Sanjuan wrote:
> > Package: installation-reports
> > Version: d-i beta4
> > Severity: important
> > 
> > 
> > 
> > -- System Information:
> > Debian Release: testing/unstable
> >   APT prefers unstable
> >   APT policy: (500, 'unstable')
> > Architecture: powerpc (ppc)
> > Kernel: Linux 2.6.5
> > Locale: LANG=es_ES@euro, LC_CTYPE=es_ES@euro
> > 
> > ====================================================================
> > 
> > INSTALL REPORT
> > 
> > Autoboot worked perfectly.
> > 
> > * First yaboot config selection:
> > I had to select install-safe-powerpc. Without automatic selection,
> > it would be fine more information about wonky framebuffer support.
> 
> Does anybody know which machines need the video=ofonly kernel parameter?
> If yes we could document this somewhere. The yaboot boot screen is probably
> to small for this...
> 
I don't know exactly. At least new albooks with newer ATI Mobility Radeon.
My advise: resend this question to debian-powerpc list.
>
> > 
> > * Partitions, filesystems, mounting:
> > I had partioned the disk drive in an earlier installation. The installer
> > recognised correctly the partition table. Partition menu is clear,
> > but help hasn't been yet translated. It might be difficult to grasp for
> > non-english speakers. I kept home partition without formatting it: data
> > were preserved after finishing the installation. Fine!
> Is this a bug? AFAIK spanish should be at 100%.
>
No problem about  main menu, but the submenu "More help" or something like
(I don't remember it exactly) is not translated. 
> > 
> > * Yaboot installation:
> > No problems at first glance, but after rebooting, wonky framebuffer
> > issue reappeared. I had to configure the base system on a flickering screen
> > and reboot again appending video=ofonly (I know the trick).
> > This is an important bug. Installer should configure yaboot such as it was
> > decided by user at first when she select install-safe.
> I cloned this report to yaboot-installer.
>
Don't forget that with 2.6.x kernels a better solution is the option:
video=radeonfb (for machines with newer ATI radeon cards), always supposing ATI
radeon new framebuffer support (FB_RADEON) is compiled in kernel. X system
doesn't work with video=ofonly.
>
> > 
> > * Spanish Keyboard map:
> > Keyboard map selections doesn't work for spanish in this machine.
> > AFAIK, this is a known problem. I had to reconfigure 'console-common' after
> > finishing installation and base system configuration with
> > the options 'Select from arquitecture/qwerty/Spanish/Standard/Standard'.
> I cloned this to kbd-chooser. Hope this is the correct package to blame for
> this...
> 
> Thanks for testing
> 
> Gaudenz
>
Greetings,

Luis Sanjuan





Reply to: