[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#247513: marked as done (wrong keymap for spanish powermac)

Your message dated Tue, 11 May 2004 17:17:04 -0400
with message-id <E1BNeca-0006za-00@newraff.debian.org>
and subject line Bug#247513: fixed in console-data 2002.12.04dbs-39
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 3 May 2004 21:06:52 +0000
>From lj.sanjuan@ya.com Mon May 03 14:06:51 2004
Return-path: <lj.sanjuan@ya.com>
Received: from smtp04.ya.com (smtp.ya.com) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BKkeJ-0004HG-00; Mon, 03 May 2004 14:06:51 -0700
Received: from [] (helo=melite)
	by smtp.ya.com with esmtp id 1BKkeD-0004XE-00; Mon, 03 May 2004 23:06:45 +0200
Received: from luis by melite with local (Exim 4.32)
	id 1BKkdZ-0004AW-5P; Mon, 03 May 2004 23:06:05 +0200
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Luis Sanjuan <lj.sanjuan@ya.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: installation-reports: Success on PowerBook G4 alu 17" (but problems with
 yaboot and spanish keyboard)
X-Mailer: reportbug 2.58
Date: Mon, 03 May 2004 23:06:05 +0200
Message-Id: <[🔎] E1BKkdZ-0004AW-5P@melite>
Sender: Luis Sanjuan <luis@melite>
X-BadReturnPath: luis@melite rewritten as lj.sanjuan@ya.com
  using "From" header
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.5 required=4.0 tests=BAYES_01,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 1

Package: installation-reports
Version: d-i beta4
Severity: important

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: powerpc (ppc)
Kernel: Linux 2.6.5
Locale: LANG=es_ES@euro, LC_CTYPE=es_ES@euro



Debian-installer-version: May 02 2004 from http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/powerpc/beta4/sarge-powerpc-netinst.iso
uname -a: Linux melite 2.4.25-powerpc #1 mer avr 14 15:38:38 CEST 2004 ppc GNU/Linux
Date: May 02 2004 11:23:40
How did you install? From a CD netinst image.
What did you boot off? Directly from CD.
If network install, from where? Via a router with DHCP server.
Proxied? No.

Machine: PowerBook G4 17" alu (PowerBook5,3)
Processor: 1333MHz
Memory: 512MB

output of cat /proc/cpuinfo:
processor       : 0
cpu             : 7457, altivec supported
clock           : 1333MHz
revision        : 1.1 (pvr 8002 0101)
bogomips        : 542.31
machine         : PowerBook5,3
motherboard     : PowerBook5,3 MacRISC3 Power Macintosh
board revision  : 00000001
detected as     : 287 (PowerBook G4 17")
pmac flags      : 0000000a
L2 cache        : 512K unified
memory          : 512MB
pmac-generation : NewWorld

Root Device: IDE: FUJITSU MHT2080AT, ATA DISK drive
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.

        #                    type name                  length   base      ( size )  system             mounted on
/dev/hda1     Apple_partition_map Apple                     63 @ 1         ( 31.5k)  Partition map
/dev/hda2         Apple_Bootstrap bootstrap               1600 @ 64        (800.0k)  NewWorld bootblock
/dev/hda3         Apple_UNIX_SVR2 swap                 2457600 @ 1664      (  1.2G)  Linux swap
/dev/hda4         Apple_UNIX_SVR2 root                  299008 @ 2459264   (146.0M)  Linux native       /
/dev/hda5         Apple_UNIX_SVR2 usr                  8388608 @ 2758272   (  4.0G)  Linux native       /usr
/dev/hda6         Apple_UNIX_SVR2 usr/local            8388608 @ 11146880  (  4.0G)  Linux native       /usr/local
/dev/hda7         Apple_UNIX_SVR2 var                  8388608 @ 19535488  (  4.0G)  Linux native       /var
/dev/hda8         Apple_UNIX_SVR2 tmp                   102400 @ 27924096  ( 50.0M)  Linux native       /tmp
/dev/hda9         Apple_UNIX_SVR2 home                39539968 @ 28026496  ( 18.9G)  Linux native       /home
/dev/hda10              Apple_HFS Apple_HFS_Untitled_3  67042112 @ 67566464  ( 32.0G)  HFS
/dev/hda11             Apple_Free Extra                 262144 @ 134608576 (128.0M)  Free space
/dev/hda12              Apple_HFS Apple_HFS_Untitled_4  21430752 @ 134870720 ( 10.2G)  HFS
/dev/hda13             Apple_Free Extra                     16 @ 156301472 (  8.0k)  Free space

Block size=512, Number of Blocks=156301488
DeviceType=0x0, DeviceId=0x0

Output of lspci and lspci -n:
0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 AGP
0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
0000:10:0b.0 Host bridge: Apple Computer Inc.: Unknown device 0035
0000:10:12.0 Network controller: Broadcom Corporation BCM94306 802.11g (rev 02)
0000:10:13.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
0000:10:17.0 Class ff00: Apple Computer Inc.: Unknown device 003e
0000:10:18.0 USB Controller: Apple Computer Inc.: Unknown device 003f
0000:10:19.0 USB Controller: Apple Computer Inc.: Unknown device 003f
0000:10:1a.0 USB Controller: Apple Computer Inc.: Unknown device 003f
0000:10:1b.0 USB Controller: NEC Corporation USB (rev 43)
0000:10:1b.1 USB Controller: NEC Corporation USB (rev 43)
0000:10:1b.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0000:24:0b.0 Host bridge: Apple Computer Inc.: Unknown device 0036
0000:24:0d.0 Class ff00: Apple Computer Inc.: Unknown device 003b
0000:24:0e.0 FireWire (IEEE 1394): Apple Computer Inc. UniNorth 2 FireWire (rev 81)
0000:24:0f.0 Ethernet controller: Apple Computer Inc. UniNorth 2 GMAC (Sun GEM) (rev 80)

0000:00:0b.0 Class 0600: 106b:0034
0000:00:10.0 Class 0300: 1002:4e50
0000:10:0b.0 Class 0600: 106b:0035
0000:10:12.0 Class 0280: 14e4:4320 (rev 02)
0000:10:13.0 Class 0607: 104c:ac56
0000:10:17.0 Class ff00: 106b:003e
0000:10:18.0 Class 0c03: 106b:003f
0000:10:19.0 Class 0c03: 106b:003f
0000:10:1a.0 Class 0c03: 106b:003f
0000:10:1b.0 Class 0c03: 1033:0035 (rev 43)
0000:10:1b.1 Class 0c03: 1033:0035 (rev 43)
0000:10:1b.2 Class 0c03: 1033:00e0 (rev 04)
0000:24:0b.0 Class 0600: 106b:0036
0000:24:0d.0 Class ff00: 106b:003b
0000:24:0e.0 Class 0c00: 106b:0031 (rev 81)
0000:24:0f.0 Class 0200: 106b:0032 (rev 80)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]


* Boot:
Autoboot worked perfectly.

* First yaboot config selection:
I had to select install-safe-powerpc. Without automatic selection,
it would be fine more information about wonky framebuffer support.

* Network detection and configuration:
Network was configured automatically without problems via my DHCP
server / router.

* Hardware detection:
No problems at all in automatic detection of CD / Hard Drive and in
loading modules.

* Partitions, filesystems, mounting:
I had partioned the disk drive in an earlier installation. The installer
recognised correctly the partition table. Partition menu is clear,
but help hasn't been yet translated. It might be difficult to grasp for
non-english speakers. I kept home partition without formatting it: data
were preserved after finishing the installation. Fine!

* Base system installation:
No problems. Automatically installed.

BUGS! =================================================================

* Yaboot installation:
No problems at first glance, but after rebooting, wonky framebuffer
issue reappeared. I had to configure the base system on a flickering screen
and reboot again appending video=ofonly (I know the trick).
This is an important bug. Installer should configure yaboot such as it was
decided by user at first when she select install-safe.

* Spanish Keyboard map:
Keyboard map selections doesn't work for spanish in this machine.
AFAIK, this is a known problem. I had to reconfigure 'console-common' after
finishing installation and base system configuration with
the options 'Select from arquitecture/qwerty/Spanish/Standard/Standard'.

Thanks a lot for your work. I hope my suggestions can help you to improve
the installer.

Received: (at 247513-close) by bugs.debian.org; 11 May 2004 21:23:06 +0000
>From katie@ftp-master.debian.org Tue May 11 14:23:06 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BNeiP-0005CW-00; Tue, 11 May 2004 14:23:05 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1BNeca-0006za-00; Tue, 11 May 2004 17:17:04 -0400
From: Alastair McKinstry <mckinstry@debian.org>
To: 247513-close@bugs.debian.org
X-Katie: $Revision: 1.49 $
Subject: Bug#247513: fixed in console-data 2002.12.04dbs-39
Message-Id: <E1BNeca-0006za-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Tue, 11 May 2004 17:17:04 -0400
Delivered-To: 247513-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 7

Source: console-data
Source-Version: 2002.12.04dbs-39

We believe that the bug you reported is fixed in the latest version of
console-data, which is due to be installed in the Debian FTP archive:

  to pool/main/c/console-data/console-data_2002.12.04dbs-39.dsc
  to pool/main/c/console-data/console-data_2002.12.04dbs-39.tar.gz
  to pool/main/c/console-data/console-data_2002.12.04dbs-39_all.deb
  to pool/main/c/console-data/console-keymaps-acorn_2002.12.04dbs-39_all.udeb
  to pool/main/c/console-data/console-keymaps-amiga_2002.12.04dbs-39_all.udeb
  to pool/main/c/console-data/console-keymaps-at_2002.12.04dbs-39_all.udeb
  to pool/main/c/console-data/console-keymaps-atari_2002.12.04dbs-39_all.udeb
  to pool/main/c/console-data/console-keymaps-dec_2002.12.04dbs-39_all.udeb
  to pool/main/c/console-data/console-keymaps-mac_2002.12.04dbs-39_all.udeb
  to pool/main/c/console-data/console-keymaps-sun_2002.12.04dbs-39_all.udeb
  to pool/main/c/console-data/console-keymaps-usb_2002.12.04dbs-39_all.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 247513@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Alastair McKinstry <mckinstry@debian.org> (supplier of updated console-data package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat,  8 May 2004 10:26:04 +0200
Source: console-data
Binary: console-keymaps-dec console-keymaps-mac console-data console-keymaps-usb console-keymaps-at console-keymaps-atari console-keymaps-sun console-keymaps-acorn console-keymaps-amiga
Architecture: source all
Version: 2002.12.04dbs-39
Distribution: unstable
Urgency: low
Maintainer: Alastair McKinstry <mckinstry@debian.org>
Changed-By: Alastair McKinstry <mckinstry@debian.org>
 console-data - Keymaps, fonts, charset maps, fallback tables for console-tools
 console-keymaps-acorn - Keymaps for Acorn RISC-PC keyboards. (udeb)
 console-keymaps-amiga - Keymaps for Amiga keyboards (udeb)
 console-keymaps-at - Keymaps for PC-style (PS/2 and AT) keyboards (udeb)
 console-keymaps-atari - Keymaps for Atari keyboards. (udeb)
 console-keymaps-dec - Keymaps for Dec keyboards (udeb)
 console-keymaps-mac - Keymaps for Apple keyboards (udeb)
 console-keymaps-sun - Keymaps for Sun keyboards (udeb)
 console-keymaps-usb - Keymaps for USB keyboards (udeb)
Closes: 238544 243175 246725 247441 247442 247449 247513
 console-data (2002.12.04dbs-39) unstable; urgency=low
   * Translations
     - Initial Romanian ro.po by Eddy Petrisor.
     - Lithuanian lt.po update by KÄ?stutis BiliÅ«nas.
     - Albanian sq.po translation by Elian Myftiu.
     - Initial Slovak translation by Peter Mann
     - Corrected German for la-latin1 and fi-latin1 by
       Christian Perrier. Closes: #247449
     - Committed Denis Barbiers Patch (sent to #248206) to fix umlauts
       Removed "(keine Tottasten)" in German translation because this only
       confuses people. by Dennis Stampfer
   * Include links for keymaps not included in d-i. Closes: #243175.
   * Use 'us' keymap as the default for Netherlands in d-i.
     Closes: #246725.
   * Use ua-utf keymap for Ukrainian. Closes: #238544.
   * Change charset in turkish keymaps for d-i. Closes: #247441.
   * Change default keymap for Turkish to trfu. Closes: #247442.
   * Add mac-es to keymaps available in debian-installer. Closes: #247513.
 1c82dcc7a26030d150cff797223303e0 763 utils important console-data_2002.12.04dbs-39.dsc
 d012ca4371bd190ec0b1ec7eb28a84ef 1245659 utils important console-data_2002.12.04dbs-39.tar.gz
 e747d32037eb630efeeb543ef0e624d4 1109360 utils important console-data_2002.12.04dbs-39_all.deb
 abf9e04eff0fb8ecc81ad827668ce70d 80410 debian-installer optional console-keymaps-at_2002.12.04dbs-39_all.udeb
 c15fbc765fec244074e4667fbb5606c8 14180 debian-installer extra console-keymaps-mac_2002.12.04dbs-39_all.udeb
 897c26d8069a60e44ef88a39af74fd3a 28414 debian-installer extra console-keymaps-sun_2002.12.04dbs-39_all.udeb
 d740837b1cbbb53cd559302adafb8bf3 79120 debian-installer extra console-keymaps-acorn_2002.12.04dbs-39_all.udeb
 f6451ec1ee4462fd721e875274c77163 12836 debian-installer extra console-keymaps-atari_2002.12.04dbs-39_all.udeb
 f3a54a0b48da12bcdf24de13a8f5ae41 18848 debian-installer extra console-keymaps-amiga_2002.12.04dbs-39_all.udeb
 c018e380b3e9f7dd05bd0d0ab1c192c0 15910 debian-installer extra console-keymaps-usb_2002.12.04dbs-39_all.udeb
 2bc1ebc46e30d304601078d428da7c51 4506 debian-installer extra console-keymaps-dec_2002.12.04dbs-39_all.udeb

Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: