[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#247218: installation-reports: Success on PowerBook G4 alu 17" (but problems with yaboot and spanish keyboard)



Package: installation-reports
Version: d-i beta4
Severity: important



-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: powerpc (ppc)
Kernel: Linux 2.6.5
Locale: LANG=es_ES@euro, LC_CTYPE=es_ES@euro

====================================================================

INSTALL REPORT

Debian-installer-version: May 02 2004 from http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/powerpc/beta4/sarge-powerpc-netinst.iso
uname -a: Linux melite 2.4.25-powerpc #1 mer avr 14 15:38:38 CEST 2004 ppc GNU/Linux
Date: May 02 2004 11:23:40
Method:
How did you install? From a CD netinst image.
What did you boot off? Directly from CD.
If network install, from where? Via a router with DHCP server.
Proxied? No.

Machine: PowerBook G4 17" alu (PowerBook5,3)
Processor: 1333MHz
Memory: 512MB

output of cat /proc/cpuinfo:
processor       : 0
cpu             : 7457, altivec supported
clock           : 1333MHz
revision        : 1.1 (pvr 8002 0101)
bogomips        : 542.31
machine         : PowerBook5,3
motherboard     : PowerBook5,3 MacRISC3 Power Macintosh
board revision  : 00000001
detected as     : 287 (PowerBook G4 17")
pmac flags      : 0000000a
L2 cache        : 512K unified
memory          : 512MB
pmac-generation : NewWorld


Root Device: IDE: FUJITSU MHT2080AT, ATA DISK drive
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.

        #                    type name                  length   base      ( size )  system             mounted on
/dev/hda1     Apple_partition_map Apple                     63 @ 1         ( 31.5k)  Partition map
/dev/hda2         Apple_Bootstrap bootstrap               1600 @ 64        (800.0k)  NewWorld bootblock
/dev/hda3         Apple_UNIX_SVR2 swap                 2457600 @ 1664      (  1.2G)  Linux swap
/dev/hda4         Apple_UNIX_SVR2 root                  299008 @ 2459264   (146.0M)  Linux native       /
/dev/hda5         Apple_UNIX_SVR2 usr                  8388608 @ 2758272   (  4.0G)  Linux native       /usr
/dev/hda6         Apple_UNIX_SVR2 usr/local            8388608 @ 11146880  (  4.0G)  Linux native       /usr/local
/dev/hda7         Apple_UNIX_SVR2 var                  8388608 @ 19535488  (  4.0G)  Linux native       /var
/dev/hda8         Apple_UNIX_SVR2 tmp                   102400 @ 27924096  ( 50.0M)  Linux native       /tmp
/dev/hda9         Apple_UNIX_SVR2 home                39539968 @ 28026496  ( 18.9G)  Linux native       /home
/dev/hda10              Apple_HFS Apple_HFS_Untitled_3  67042112 @ 67566464  ( 32.0G)  HFS
/dev/hda11             Apple_Free Extra                 262144 @ 134608576 (128.0M)  Free space
/dev/hda12              Apple_HFS Apple_HFS_Untitled_4  21430752 @ 134870720 ( 10.2G)  HFS
/dev/hda13             Apple_Free Extra                     16 @ 156301472 (  8.0k)  Free space

Block size=512, Number of Blocks=156301488
DeviceType=0x0, DeviceId=0x0

Output of lspci and lspci -n:
0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 AGP
0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
0000:10:0b.0 Host bridge: Apple Computer Inc.: Unknown device 0035
0000:10:12.0 Network controller: Broadcom Corporation BCM94306 802.11g (rev 02)
0000:10:13.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
0000:10:17.0 Class ff00: Apple Computer Inc.: Unknown device 003e
0000:10:18.0 USB Controller: Apple Computer Inc.: Unknown device 003f
0000:10:19.0 USB Controller: Apple Computer Inc.: Unknown device 003f
0000:10:1a.0 USB Controller: Apple Computer Inc.: Unknown device 003f
0000:10:1b.0 USB Controller: NEC Corporation USB (rev 43)
0000:10:1b.1 USB Controller: NEC Corporation USB (rev 43)
0000:10:1b.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0000:24:0b.0 Host bridge: Apple Computer Inc.: Unknown device 0036
0000:24:0d.0 Class ff00: Apple Computer Inc.: Unknown device 003b
0000:24:0e.0 FireWire (IEEE 1394): Apple Computer Inc. UniNorth 2 FireWire (rev 81)
0000:24:0f.0 Ethernet controller: Apple Computer Inc. UniNorth 2 GMAC (Sun GEM) (rev 80)

0000:00:0b.0 Class 0600: 106b:0034
0000:00:10.0 Class 0300: 1002:4e50
0000:10:0b.0 Class 0600: 106b:0035
0000:10:12.0 Class 0280: 14e4:4320 (rev 02)
0000:10:13.0 Class 0607: 104c:ac56
0000:10:17.0 Class ff00: 106b:003e
0000:10:18.0 Class 0c03: 106b:003f
0000:10:19.0 Class 0c03: 106b:003f
0000:10:1a.0 Class 0c03: 106b:003f
0000:10:1b.0 Class 0c03: 1033:0035 (rev 43)
0000:10:1b.1 Class 0c03: 1033:0035 (rev 43)
0000:10:1b.2 Class 0c03: 1033:00e0 (rev 04)
0000:24:0b.0 Class 0600: 106b:0036
0000:24:0d.0 Class ff00: 106b:003b
0000:24:0e.0 Class 0c00: 106b:0031 (rev 81)
0000:24:0f.0 Class 0200: 106b:0032 (rev 80)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]

Comments/Problems:

* Boot:
Autoboot worked perfectly.

* First yaboot config selection:
I had to select install-safe-powerpc. Without automatic selection,
it would be fine more information about wonky framebuffer support.

* Network detection and configuration:
Network was configured automatically without problems via my DHCP
server / router.

* Hardware detection:
No problems at all in automatic detection of CD / Hard Drive and in
loading modules.

* Partitions, filesystems, mounting:
I had partioned the disk drive in an earlier installation. The installer
recognised correctly the partition table. Partition menu is clear,
but help hasn't been yet translated. It might be difficult to grasp for
non-english speakers. I kept home partition without formatting it: data
were preserved after finishing the installation. Fine!

* Base system installation:
No problems. Automatically installed.

BUGS! =================================================================

* Yaboot installation:
No problems at first glance, but after rebooting, wonky framebuffer
issue reappeared. I had to configure the base system on a flickering screen
and reboot again appending video=ofonly (I know the trick).
This is an important bug. Installer should configure yaboot such as it was
decided by user at first when she select install-safe.

* Spanish Keyboard map:
Keyboard map selections doesn't work for spanish in this machine.
AFAIK, this is a known problem. I had to reconfigure 'console-common' after
finishing installation and base system configuration with
the options 'Select from arquitecture/qwerty/Spanish/Standard/Standard'.

Thanks a lot for your work. I hope my suggestions can help you to improve
the installer.



Reply to: