[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DHCP failure during install



Hi,

At Thu, 1 Apr 2004 17:12:02 -0500,
Joey Hess wrote:
> russh347@charter.net wrote:
>   * Kenshi Muto
>     - modprobe in busybox won't load af_packet. This causes DHCP
>       configuration fail.
>       This can be avoid by running modprobe without '/sbin/'.
> 
> But I don't understand this fix, as modprobe is in /sbin/ anyway. Also, I
> can't reproduce the problem with the current unfixed version of netcfg, it
> loads af_packet just fine. Kenshi?

I'm sorry I forgot to report to debian-boot (why am I so busy...?).
But I reproduced this problem on my environment, i386 VMware 4+yesterday
sid snapshot CD image.
I saw 'DHCP fail' message at install stage, and tried to find what's
happen.

I tried to run '/sbin/modprobe af_packet' and got 'Error inserting
af_packet (/lib/modules/2.4.25-1-386/kernel/net/packet/af_packet.o):
Unknown symbol in module, or unknown parameter (see dmesg)'.
I was very wondering what was this, but when I tried to run 'modprobe
af_packet', problem was gone.

I don't know why this problem is happen (in busybox?), but at least
removing '/sbin/' solves this. I've already checked fixed netcfg
package.

Thanks,
-- 
Kenshi Muto
kmuto@debian.org



Reply to: