[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sarge/beta-3 on a RS6000/7025-F50 (PPC 604e, CHRP)

On Mon, Mar 22, 2004 at 01:24:48PM +0100, Marco d'Itri wrote:
> On Mar 22, Sven Luther <sven.luther@wanadoo.fr> wrote:
> > > No, wait... we really want to use yaboot.
> > And, are you sure yaboot works on PReP machines ? Not on CHRP boxes
> I really don't know.
> But at least on CHRP machines it *should* be used.

Unless you don't want to. I believe that having yaboot.udeb installable
on pmac_newworld and chrp(all) should be ok, we can then make a
prep_installer which would be lower priority than yaboot but higher than
nobootloader, so prep user will get it, and chrp-rs6k users can get it
in expert mode if they want to.

> > > I used to dd the kernel on my B50 but had to stop after upgrading to 2.6
> > > because newer kernels cannot be loaded without a boot loader.
> > Mmm, have you more info on this ? I have no problem booting my
> > pegasos/chrp with the 2.6.4 builtin chrp boot-loader.
> I do not remember the details, but OF would try to load the kernel and
> then go back to the prompt with some error message. I discussed this
> with the PPC kernel hackers and everybody agreed that I should just use
> yaboot.

Mmm, strange.

> > BTW, can you test the 2.4.25-4 kernel on this B50 of yours ? It should
> > work, but it was never really tested.
> It's a remote box, sorry. :-)


> > > To install yaboot /usr/lib/yaboot/yaboot must be prepared with
> > > /usr/lib/yaboot/addnote and then copied to the PReP partition.
> > > yaboot is able to load plain zImage kernels.
> > Ah, i had the understanding that yaboot only understands plain
> > uncompressed elf vmlinux kernels.
> I confirm this:
> /boot/vmlinuz-2.6.3-b50: ELF 32-bit MSB executable, PowerPC or cisco 4500, version 1 (SYSV), statically linked, not stripped
> -rw-r--r--    1 root     root      1558724 Feb 20 02:35 /boot/vmlinuz-2.6.3-b50

Ok. Maybe it only doesn't work on pmacs then.


Sven Luther

Reply to: