[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#231601: Package: installation-reports

Package: installation-reports

Debian-installer-version: 02-january-2004 - from official debian.org
uname-a: Linux kibi 2.6.2 #13 Sat Feb 7 01:40:56 EST 2004 i686 GNU/Linux
(later installed custom kernel)Date: Wednesday 4 februari
Method: Network install from floppy, using mirror ftp.nl.debian.org, no
proxy, used "load installation modules from the internet" right after boot
Machine: Aspire1300 notebook
Processor: mobile AMD Athlon(tm) XP 1800+ (1500MHz)
Memory: 256 MB
Root Device: IDE
Root Size/partition table:
detach@kibi:~$ sudo fdisk -l /dev/hda

Disk /dev/hda: 20.0 GB, 20003880960 bytes
16 heads, 63 sectors/track, 38760 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        1938      976720+  83  Linux
/dev/hda2            1939        2326      195552   82  Linux swap
/dev/hda3            2327       38760    18362736   8e  Linux LVM

Output of lspci:

detach@kibi:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev
80)00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
00:11.0 ISA bridge: VIA Technologies, Inc. VT8231 [PCI-to-ISA Bridge] (rev
10)00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06)00:11.2 USB Controller: VIA Technologies, Inc. USB (rev 1e)
00:11.4 Bridge: VIA Technologies, Inc. VT8235 ACPI (rev 10)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97
Audio Controller (rev 40)00:11.6 Communication controller: VIA Technologies, Inc. Intel 537 [AC97
Modem] (rev 20)00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev
51)01:00.0 VGA compatible controller: S3 Inc. VT8636A [ProSavage KN133] AGP4X
VGA Controller (TwisterK) (rev 01)
Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [ ] (worked directly from boot)
Config network:         [ ] (DHCP worked automagically)
Detect CD:              [O] (worked)
Load installer modules: [O] (worked)
Detect hard drives:     [ ]
Partition hard drives:  [O]
Create file systems:    [E] (LVM problem)
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [E]
Reboot:                 [X]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Booting (worked well)

First, the network detection, DHCP etc. worked perfect.

Dutch Language Implementation (not perfect)

Language settings worked perfectly although the dutch language used was a
little silly, for example the language used some literal translations for
for example "mount" of which we never use a dutch translation as it sounds
silly, but that's a minor thing.
Create LVM filesystem (didn't create physical volume)

First, I wanted to use LVM so after I partitioned my harddrives it
directly wanted to format and mount the new partitions.. It would be
better if it checked whether I made an LVM partition so I have a chance to
setup LVM. But this was not a major problem as I could just hit "abort"
and go to the LVM setup and after that go back to formatting and mounting
the partions and the root partition.Also, I understand the installer *tries* to find the best next thing.

Second, LVM setup doesn't work out of the box. You see, it skips the
pvcreate phase, so i had to open a shell and create the physical volume by
hand.. Only after that I could go to the menu item on LVM to create volume
groups and LVs. It makes sense that this LVM option tries asks to create
the physical volume.
The rest of the volume creation and EXT3 formatting the individual LVs
worked just fine.. LVs:

Install base system: (not complete)

The base system failed (or to my knowledge didn't even try) to install the
kernel. I repeated this step over and over, I saw it downloaded a
kernel_image but immediately after downloading this (udeb?) it got
removed. It was never installed. I also got an error when it tried to
install debootstrap.. I'm sorry I do not have the exact error message.Next I tried to install both LILO (which failed) and grub.. both failed.
They defaulted to the devfs path of the first partition (part1). I think
it would be easier to see if it was installing in MBR or on the first
partition.. that part was very unclear.Installing in /dev/ide/host0/target0/lun0/disc failed.. all failed..
/dev/hda didn't exist so that wouldn't work either.I'm personally not very familiar with devfs though.. I have had a debian
developer look at it (wilmer van der gaast) he quickly left me alone
because this was not going to work.
I managed to get it working by chrooting to /target, then mounting /proc,
then doing apt-get install kernel-image-2.4.22-1-386. Then I ran lilo and
it was working.. The lilo file contained:
        label="DEB 2.4.22-0"

Install bootloader: (did not work)

This did not work as mentioned in the above section. If I entered a
nonexisting part to the harddisk (like /dev/hda) it would just exit
without giving errors (I've also tried to run the lilo.bootconf(??) or
something from the /var/lib/dpkg/info/ directory).. it didn't give errors
like; 'doesn't exist', but I guess it gave back an error value because
from the menu it said lilo failed.
After I installed lilo manually and said in the menu 'finish and reboot'
there was no error anymore.. it recognized that the system now worked.
I hope this report is helpful..

]- detach [The Hackaholic <http://hackaholic.org/>]
-[ PGP KEY ID; 0X80FD4B50

Reply to: