[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Integrity checks failing

--- Joey Hess <joey@kitenet.net> wrote:
> James J. Ramsey wrote:
> > When I attempted to install with the 2003-12-31
> > netinst CD, not long after I did the language
> > selection, I got an error message like this:
> > 
> > "The integrity check for <FOO> failed. It is most
> > likely corrupt. Aborting."
> > 
> > After that, I was able to reboot and get back to
> my
> > old system.
> > 
> > <FOO> varies a bit. On one attempted install, it
> was
> > "base-installer"; on another "baseconfig-udeb"; on
> > still another "bterm-unifont." I thought the
> problem
> > might be DMA-related, because I have an older
> > that does screwy things when DMA is enabled for
> it.
> > However, starting the install by typing "linux
> > ide=nodma" at the "boot:" prompt did not change
> > anything.
> Have you tried writing a new CD using a different CD
> burner? 

Nope. I only have access to one CD burner (which has
so far never given me a CD that appeared to burn
properly but turned out bad). I did make two copies of
the CD, though, and both of them had the same problem.
I just burned the latest image (2003/1/1) tonight, and
I'll see what that gets me tomorrow.

> I can
> verify that the problem means it is getting some
> corrupted data in a
> file from the CD, but the CDs we ship do not have
> corrupted files on
> them.

That's why I tried the ide=nodma boot option.
Complaints about corrupted files are exactly the kind
of error messages that I'll see if my old 8x CD-ROM
drive is accessed via DMA. (This drive has otherwise
been quite reliable.)

BTW, kudos for doing integrity checks before writing
anything to the hard drive. It makes all the
difference between a minor annoyance and a more
time-consuming reinstall.

Do you Yahoo!?
Find out what made the Top Yahoo! Searches of 2003

Reply to: