[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

d-i experiences


The following is a record of my d-i experiences today...

I took a little time out at work today to try d-i.

I fired up a bochs machine and booted the netinst CD

It sat looping saying "unable to load vesafb.o"

This was a bit of a disappointment, so I waited until I got home.

Once at home, I figured I'd do what I consider the most common form of
installation I do. I.E. the equivalent of install from boot/root/drivers
-- I downloaded the businesscard ISO and fired up a vmware.

The following are my notes following the hitting of 'enter' at the boot
prompt. They're pretty much in order and can be considered to be
regarding the use of the businesscard installer on x86 as I found on
http://gluck.debian.org/cdimage/testing/netinst/i386/ after Sebastian's
posting to debian-devel-announce.

Firstly, the framebuffer console is incredibly slow. But I can cope with

The first menu d-i presented me with having booted was in English. It's
very very lucky I speak english, or I wouldn't have known to press Enter
in order to be able to select English as my language of choice for the

I selected 'detect cdrom' and d-i kindly told me there'd been an error
whose text was 'EXIT' before succeeding to detect the cdrom

On the loading modules page, many of the descriptions don't fit, this is
poor UI design

At this point, I hit 'go back' twice because I didn't want to install
any modules and couldn't see what to do.

On the second 'go back' I got an error. Apparently anna's postinst
(whoever anna is) exited with status 2560 (whatever that means)

Eventually I worked out that I wanted to 'continue' past the modules
page without selecting any modules (mmm intuitive)

Following this, we tried to configure the modules. This went acceptably,
although many descriptions overflowed the dialog they were meant to fit

I decided to configure my NIC by DHCP. I selected this option and
answered the questions it asked me. It then presented me with what
looked like a post-DHCP configuration output and asked me if it was

After realising that this was the pre-DHCP dialog, I continued,
continued again, and ended up back at the main menu with no indication
of whether or not the DHCP succeeded. All I knew was that d-i had
highlighted the PPP/serial option suggesting to me that DHCP had failed.
(It hadn't)

I then decided to configure which mirror to install Debian from. But the
UK appeared to be missing from the list, so I configured the mirror
manually and was returned to the main menu, with PPP/serial selected

Having partitioned my drive the hard way I tried to create filesystems.
The d-i businesscard installer appears to be missing reiserfs as a
default option for filesystems. This is poor and should be rectified.
After all, the bf24 bootfloppies series managed it.

This part of d-i failed to take notice of my partition types and kindly
offered the option of creating swap on my / partition, and indeed
creating an ext3 filesystem on my swap partition.

As I fought my way through the partitioning and formatting options I got
many error dialogs containing what look like the output of cfdisk, only
containing piles of escape strings too.

I selected 'install packages' and wandered off to another terminal
because it made the the install go a lot faster. I happened to chance
upon the syslog terminal which seemed to be logging a whole pile of
errors of the form:

installer[21577]: WF: Retrying failed download of %s

Where the %s really was '%s', I'm not introducing a placeholder here,
the error message was failing to perform the substitution.

After installing base, the 'debian-installer' process exited and was
restarted according to the syslog console

I chose install-kernel, unfortunately d-i seemed to think I should
install base again. It chundered through for a bit and then gave up,
giving me the error that debootstrap had failed and I should look in
/target/var/log/debootstrap.log for information.

It seems debootstrap barfed on an id call, something to do with [ and
then an attempt to ln /usr/bin/awk

At this point I decided I'd not get a working system, so I stopped the
vmware and wrote this email instead.

If this is the current state of the installer, I'm very concerned that
we'll not be able to release sarge on time; or that we'll have to fall
back to boot-floppies for the most part.



Daniel Silverstone <dsilvers@debian.org>

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: