[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Install report, laptop with USB CD-ROM

I tried debian-installer on a laptop today which doesn't have an
internal CD or floppy drive.  It has a CD-ROM drive connected via USB,
though.  I used the cdrom-image.img from

Some things I noticed:

 - The screen on F4 doesn't show /var/log/syslog.  Instead, it shows:
tail: /var/log/syslog: No such file or directory
tail: no files

  This is perhaps because /var/log/syslog doesn't exist in the image
  (/var/log/messages exists.)

 - I got an error about loading the floppy, namely:

|An error occured while running 'modprobe -v floppy'
|  Something must have gone wrong.

   F3 shows: modprobe: failed to load module floppy
   And typing "insmod floppy" on F2 shows: "insmod: init_module: floppy: No such device"
   Well, doh, I don't have a floppy.

 - It said: "A CDROM reader has been found with the following CD
inserted: CDNAME You can continue the install."

   It literally said "CDNAME" instead of using the name of the CD.  I think
this is because of:
| db_subst cdrom-detect/success cdname "CDNAME"·

   Shouldn't this be "$CDNAME" ?

 - Also, looking through the template files, I see that sometimes a
   space is put before a question mark, and sometimes no space is
   there (ie. "foo ?" vs "foo?").  This should be unified.

 - Ok, the most important part... the USB CD-ROM is not recognized...
   It needs the usb-storage module.  I worked around this problem by
   manually putting the usb-storage module in the image and rerunning
   depmod.  When I boot, I can then manually insert the module on F2
   and d-i will then find the CDROM.  So 2 things are needed for d-i
   to support USB CD-ROMs: 1. the usb-modules udeb needs the
   usb-storage module.  I will file a bug about this.  2. You need to
   load the usb-storage module.  I did it manually, but this should
   really be done automatically.

Martin Michlmayr

Reply to: