[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installation attempt with latest netinst

tor 2003-04-10 klockan 23.35 skrev Robert Vollmert:

> The kernel booted flawlessly. Actually, hardware support didn't seem
> to be a problem as far as we got.

That sounds good. :)

> The keyboard worked fine with English layout. Selecting the German
> keymap didn't actually change the keymap. We tried both the PS/2 and
> USB keyboard -- I don't really know how it is really connected, though
> I'd guess PS/2. Not a big problem, though.

Hmm, this is a bug that should be reported on kbd-chooser. I don't know
what a German keyboard is supposed to look like, but picking Swedish
keyboard works fine for me, so there must be a bug somewhere.

> CD-ROM detection worked well. The installer module installtion seemed
> to work fine, although there were some error messages I couldn't
> place. I didn't write them down and don't have access to the machine
> currently, but could try to get them tomorrow.

Error messages during CD-ROM detection, or during loading installation

> The network device was apparently probed successfully. However, the
> static network setup failed because ifconfig didn't work -- busybox
> printed its list of commands when calling ifconfig from the console.

Argh. That's probably because busybox-cvs has been installed and
overwritten busybox. busybox-cvs doesn't have ifconfig...

I wonder if we can get around this by using hard links instead of
symlinks with busybox... That and letting udpkg remove files before
overwriting them... Hmm.

> We then tried the harddisk setup, using the all-in-one option. The
> drive had already been partitioned with Partition Magic, which also
> created filesystems. However, we didn't get the option to mount these
> partitions without first choosing what filesystems to create. This
> also happened on a second installation attempt, where the filesystems
> had definitely been created correctly. After entering the mountpoints,
> this module finished successfully.

Yes, this is a bug in partconf that I'm aware of, and working on fixing.

> As checked from the console, the partitions were mounted correctly.
> However, /target/etc/fstab was not created, which caused the next
> modules to fail. In particular, installing base from CD-ROM failed.

Right, we're working on that but have a few bugs to hammer out of the
mkfstab program.

Many thanks for the report!

Martin Sjögren
  sjogren@debian.org -- marvin@dum.chalmers.se
  GPG key: http://www.mdstud.chalmers.se/~md9ms/gpg.html
  let hello = "hello" : hello in putStr (unlines hello)

Attachment: signature.asc
Description: Detta =?ISO-8859-1?Q?=E4r?= en digitalt signerad meddelandedel

Reply to: