[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation report


Debian-installer-version: poeple.d.o/~tfheen/d-i/images/daily
    got vmlinuz and net-initrd.gz at around 23:00, Dec 7
uname -a: sorry, didn't care
Date: approx. Dec 7, 23:00-3:00
    I tried to install sid, then sarge from http://mir2.ovh.net/debian
    (no proxy)
    I downloaded vmlinuz and net-initrd.gz into my boot partition
    (which didn't move), and booted them with an already-installed grub.

Machine: standard i386 pc
Processor: /proc/cpuinfo says "Pentium II (Deschutes)"
Memory: 128Mb
Root Device: /dev/hda7
Root Size/partition table:

/dev/discs/disc0/part1   *         1         7     56196   83  Linux
/dev/discs/disc0/part2             8        40    265072+  82  Linux swap
/dev/discs/disc0/part4            41      1232   9574740    5  Extended
/dev/discs/disc0/part5            41       232   1542208+  83  Linux
/dev/discs/disc0/part6           233       360   1028128+  83  Linux
/dev/discs/disc0/part7           361       488   1028128+  83  Linux
/dev/discs/disc0/part8           514      1232   5775336   83  Linux

part1 is /boot
part5 is /home
part6 is /var/cache/apt
part7 is /
part8 is an old thing with old things that needed to be kept...

Output of lspci:

(if you really care...)
00:00.0 Host bridge: Intel Corp. 440LX/EX - 82443LX/EX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440LX/EX - 82443LX/EX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 01)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation NV5 [Riva TnT2] (rev

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O] (but no detection, ne 2000 isa non-pnp)
Config network:         [O] (the static method)
Detect CD:              [ ]
Load installer modules: [E]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [x] well, under torture it failed... :)
Install base system:    [E]
Install boot loader:    [ ]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems: many ;)

After running the installation stuff a dozen times, i finally succeded in
installing a sarge. I had many many problems...

* Notes before starting

I already had a sid installed. I saved my apt cache packages and /home in
/dev/hda8, and started installation using grub and files in my /boot

* The generic ones :

- At the retreiver selection step, something needed libdebconf.so.0.3, while
  the initrd contained only 1.0. I needed to symlink it to the wanted file
  to get things work. Maybe some other problems i had are related. I've just
  seen in some list that someone else reported this.

- I tried ftp one time. The installtion tried to fetch from http:///debian,
  which didn't work ;)

- The first time, I have been quite sadic with d-i when it asked me to mount
  paritions. I tried mounting non-root partitions first ;) I mounted /home,
  and it didn't protest, I mounted /var/cache/apt (using the "manual"
  choice), which gave me an awful error, but mounted the partition.

* While trying to install sid :

- The installation failed while "configuring base packages", or something
  like that. I rebooted installation and tried using debootstrap directly
  (instead of running the base system installation step). Debootstrap tried
  to run something like :
  	chroot /target dpkg -i .../libc6_2.2... .../libc6_2.3...
  of course, while configuring libc6 2.2, which had just been installed,
  bash didn't find GLIBC_2.3 ;)

  I think this was because I copied my whole (old) apt cache into
  /target/var/cache/apt/archives before running, to save download time (and
  that worked...) I hadn't had this problem with sarge, but this time i
  chose to download all the packages...

* Having finally got a sarge installed, rebooting...

(btw, i needed to umount -a; reboot by hand since choice 11 did't want to do
that until i installed a bootloader, which i didn't want.)

- I tried to boot the kernel just installed with grub. It panic'd, could
  not mount the root (correctly specified on command line). It seems it had
  no ide driver...

- I booted the new system with an old custom kernel. It was devfs, no luck.
  I couldn't get a getty. Needed to reboot single single user, changs
  fstab and inittab.

- The generated /etc/network/interfaces was wrong, using dhcp method instead
  of static.

* Conclusion

- I'm going to sleep (4:30 am). I didn't configure my system yet, and
  probably won't before a few days. I have a home server/nat which i can use
  until then (i use it to write this mail). If some of you want me to give
  you clearer results or do some further tests, i can. I have just
  subscribed to this list (i'd like to help). Don't hesitate asking me more
  things if you need.

  Hope it wasn't too long and boring you with false problems that were my
  fault. Sorry for my poor english, too.

Jeremie Koenig <sprite@sprite.fr.eu.org>

Reply to: