[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation report

sön 2002-12-08 klockan 04.47 skrev Jeremie Koenig:
> Base System Installation Checklist:
> Initial boot worked:    [O]
> Configure network HW:   [O] (but no detection, ne 2000 isa non-pnp)
> Config network:         [O] (the static method)
> Detect CD:              [ ]
> Load installer modules: [E]
> Detect hard drives:     [O]
> Partition hard drives:  [O]
> Create file systems:    [O]
> Mount partitions:       [x] well, under torture it failed... :)
> Install base system:    [E]
> Install boot loader:    [ ]
> Reboot:                 [E]
> [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
> Comments/Problems: many ;)
> After running the installation stuff a dozen times, i finally succeded in
> installing a sarge. I had many many problems...
> * Notes before starting
> I already had a sid installed. I saved my apt cache packages and /home in
> /dev/hda8, and started installation using grub and files in my /boot
> partition.
> * The generic ones :
> - At the retreiver selection step, something needed libdebconf.so.0.3, while
>   the initrd contained only 1.0. I needed to symlink it to the wanted file
>   to get things work. Maybe some other problems i had are related. I've just
>   seen in some list that someone else reported this.

Yes, this is a big mistake on our part, we forgot to re-upload
net-retriever, so 0.014 is still compiled against libdebconf0.3. 0.015
should hit the mirrors soon, which will fix this.

> - I tried ftp one time. The installtion tried to fetch from http:///debian,
>   which didn't work ;)

ftp is on the TODO, that should've been mentioned, sorry about that.

> - The first time, I have been quite sadic with d-i when it asked me to mount
>   paritions. I tried mounting non-root partitions first ;) I mounted /home,
>   and it didn't protest, I mounted /var/cache/apt (using the "manual"
>   choice), which gave me an awful error, but mounted the partition.

The mounting tool is undergoing a rewrite too :) Perhaps it would make
sense not to actually mount the partitions until the user has made all
his choices.

> * While trying to install sid :

We haven't really tested it for sid, I think. At least I haven't.

> - The installation failed while "configuring base packages", or something
>   like that. I rebooted installation and tried using debootstrap directly
>   (instead of running the base system installation step). Debootstrap tried
>   to run something like :
>   	chroot /target dpkg -i .../libc6_2.2... .../libc6_2.3...
>   of course, while configuring libc6 2.2, which had just been installed,
>   bash didn't find GLIBC_2.3 ;)

> * Having finally got a sarge installed, rebooting...
> (btw, i needed to umount -a; reboot by hand since choice 11 did't want to do
> that until i installed a bootloader, which i didn't want.)

Yeah, we need a more flexible way for skipping steps.

> - I tried to boot the kernel just installed with grub. It panic'd, could
>   not mount the root (correctly specified on command line). It seems it had
>   no ide driver...
> - I booted the new system with an old custom kernel. It was devfs, no luck.
>   I couldn't get a getty. Needed to reboot single single user, changs
>   fstab and inittab.

Well, the generated /target/etc/fstab doesn't use devfs, so if you try
to boot a kernel with devfs, you're going to have problems, yes...

> - The generated /etc/network/interfaces was wrong, using dhcp method instead
>   of static.

What do you mean? Had you used dhcp during the install but it wrote
config for static? Or the opposite? netcfg is undergoing a rewrite too

>   Hope it wasn't too long and boring you with false problems that were my
>   fault. Sorry for my poor english, too.

Thanks a lot!

Attachment: signature.asc
Description: Detta =?ISO-8859-1?Q?=E4r?= en digitalt signerad meddelandedel

Reply to: