[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation report

* Jeremie Koenig 

| After running the installation stuff a dozen times, i finally succeded in
| installing a sarge. I had many many problems...

Sid might install by accident, but no promises there.  :)

| - At the retreiver selection step, something needed
| libdebconf.so.0.3, while the initrd contained only 1.0. I needed to
| symlink it to the wanted file to get things work. Maybe some other
| problems i had are related. I've just seen in some list that someone
| else reported this.

Noel Koethe's problem was something else, which was fixed by fixing my
build scripts.  The initrds are fine, but the version in the archive
might be broken.  (net-retriever is broken until tomorrow, for instance)

| - I tried ftp one time. The installtion tried to fetch from http:///debian,
|   which didn't work ;)

ftp is partially missing, yes. :)

| - The first time, I have been quite sadic with d-i when it asked me to mount
|   paritions. I tried mounting non-root partitions first ;) I mounted /home,
|   and it didn't protest, I mounted /var/cache/apt (using the "manual"
|   choice), which gave me an awful error, but mounted the partition.

did it manage to mount the root at all?  maybe it should force
mounting root before other partitions, or at least give out a warning
that you have your foot in front of the shotgun, and ask whether you
want to move foot before pulling the trigger.

|   I think this was because I copied my whole (old) apt cache into
|   /target/var/cache/apt/archives before running, to save download time (and
|   that worked...) I hadn't had this problem with sarge, but this time i
|   chose to download all the packages...

This sounds like

| (btw, i needed to umount -a; reboot by hand since choice 11 did't want to do
| that until i installed a bootloader, which i didn't want.)

ack, and see Martin's reply.

| - I tried to boot the kernel just installed with grub. It panic'd, could
|   not mount the root (correctly specified on command line). It seems it had
|   no ide driver...

it uses an initrd, so you need to point grub to that.

| - I booted the new system with an old custom kernel. It was devfs, no luck.
|   I couldn't get a getty. Needed to reboot single single user, changs
|   fstab and inittab.

devfs is only used in the installer, not after boot, and unless you
run devfsd things will break, sorry.  Anybody got a good idea on how
to solve this?

| - The generated /etc/network/interfaces was wrong, using dhcp method instead
|   of static.

Noted, I think this might have to do with you rebooting by hand, since
the /etc/network/interfaces is supposed to be run by prebaseconfig scripts.

| - I'm going to sleep (4:30 am). I didn't configure my system yet, and
|   probably won't before a few days. I have a home server/nat which i can use
|   until then (i use it to write this mail). If some of you want me to give
|   you clearer results or do some further tests, i can. I have just
|   subscribed to this list (i'd like to help). Don't hesitate asking me more
|   things if you need.

Thanks for the report!  You point out a lot of stuff which we'd not
expected somebody to do, and some stuff which I guessed would break,
and we'll start fixing those things ASAP.

Tollef Fog Heen                                                        ,''`.
UNIX is user friendly, it's just picky about who its friends are      : :' :
                                                                      `. `' 

Reply to: