[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Still unable to 'Initialize a Linux Partition' with bf 3.0.21

On Sun, Mar 17, 2002 at 12:32:59AM +0100, Andreas W?st wrote:
> Hi
> I've already reported this problem with bf-3.0.19 to both of these lists. On
> linux-apus-devel I was told this would be a kernel issue, but on debian-boot, Chris told
> me it would be a dbootsrap issue and should be fixed.
> Today I've downloaded the root.bin from http://people.debian.org/~aph/debian/dists/woody/main/disks-powerpc/3.0.21-2002-03-13/apus/images-1.44/
> Adam built and replaced the 3.0.19 root.bin in the apus/images-1.44/ folder with the new one. Still
> using the 2.4.17 apus kernel.
> But, unlucky me, nothings seems to have changed, the bug still appears,
> and so I still can't Initialize a Linux partition.
> I've quoted myself in the following lines just to give a short overview over the
> problem itself:
> > [First thing is,] that it is not possible to execute the point "Initialize a
> > Linux Partition". After selecting this point in the menu, the screen goes
> > white, and the installer system restarts!
> >
> > On console 3 I could read:
> >
> >    Mar 3 ... (none) user.info init: Process '/sbin/udbootstrap' (pid 140) exited. Scheduling it for restart
> >
> >    Mar 3 ... (none) user.info init: Starting pid 146, console /dev/console: '/sbin/udbootstrap'
> Here I have to say that it now also didn't want to work with a virgin disk
> without an already valid root partition (but of course already partitioned
> from the AmigaOS side).
> I wonder about this, because the 'Initialize..' part worked perfectly well with an
> 2.4.9 apus kernel (but this isn't much use to me, as 2.4.9 doesn't support dhcp, and so I can't install
> the rest of the system after the reboot *snif*).
> I hope you can see my dilemma: kernel 2.4.9 is the only one which supports my
> NIC and I can 'Initialize...', but it doesn't support DHCP. 2.4.17 does support my NIC and DHCP, but I
> can't 'Initialize...'..
> ps: Why are the driver-1.bin and rescue.bin files in .../apus/images-1.44/ still built, although
> they doesn't seem to be needed?
> pps: Does the new color of the selection bar really have to be red? It gives a
> very bad contrast with the underlying text. Lucky me I've already tried to
> install debian that much that I can recall the selection lines from my mind.
> And oh, concerning the ongoing 'malformed release file' discussion: I very often
> got this message in the last few weeks (when I've been trying to install with
> other kernels than 2.4.17, but, as I said, no success with them, because of
> the lacking dhcp support..)!!
> -- 
> Thanks for any idea, kind regards,
> Andi

How about trying mke2fs /dev/whatever from the virtual console 2? 
Does that give an error message?

If that works, and you can mount it as root, at least you could go on
with the install.
*------v--------- Installing Debian GNU/Linux 3.0 --------v------*
|      <http://www.debian.org/releases/woody/installmanual>      |
|   debian-imac (potato): <http://debian-imac.sourceforge.net>   |
|            Chris Tillman        tillman@voicetrak.com          |
|                   May the Source be with you                   |

Reply to: