[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#123325: -pic packages lack depends

On Mon, Dec 10, 2001 at 06:05:56PM -0500, Adam Di Carlo wrote:
> Package: libnewt-pic, libnewt-utf8-pic
> Version: 0.50.17-7.3
> Severity: serious
> The libnewt*-pic packages require a versioned dependancy (=
> <current-version>) on the libnewt* packge they go with.  Thus
> libnewt-utf8-pic must depend on 'libnewt-utf8-0 (= 0.50.17-7.3)' and
> libnewt-pic must depend on 'libnewt0 (= 0.50.17-7.3)'.
> This bug violates a policy "must" condition because this dependancy is
> implied in the very nature of what the -pic package is for.

I fail to see why the -pic packages depend on the non -pic packages.
As you know, the -pic packages contain only a library of routines
compiled with PIC. Those routines can be extracted from the library and
used to build subsets of the newt shared library, without needing to use
the shared library itself in the process, and that's what this packages
are for, so, I don't see why they must depend on the non -pic
packages...  May you explain that to me, or point me to the relevant
thread on debian-*, please?

Enrique Zanardi					ezanardi@id-agora.com

Reply to: