[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with building the Alpha-bootdisks



On Tue, Jul 24, 2001 at 10:38:30AM +0200, Martin Schulze wrote:
> From a first glance it looks like a dependency problem:
> 
> sysvinit: Depends e2fsprogs (>= 1.15-1)
> e2fsprogs: version 1.22-1 is available, but:
> e2fsprogs-bf version 1.22-1 will be installed, so the dependency is
> not fulfilled.
> 
> I guess that sysvinit should have a dependency like
> 
> e2fsprogs (>= 1.15-1) | e2fsprogs-bf (>= 1.15-1)

Well, I thought about that as well, but if sysvinit had these
dependencies a user and/or apt could get the idea that installing
e2fsprogs-bf seems like a good idea which it is not (out of the
description of e2fsprogs-bf):

| Don't attempt to install this package, it has no support for a
| couple of features you surely want.  Anyway it should refuse to
| install.

This could give raise to a bunch of bad bug reports... 

Anyway, it seems that the downloading of the packages needed for the
boot-floppies seems to be broken if there is no way of getting apt to
download package-files without checking.

CU
    Thimo

-- 
Thimo Neubauer <thimo@debian.org>
Debian GNU/Linux 3.0 semi-frozen! See http://www.debian.org/ for details

Attachment: pgpBVR33DNFiG.pgp
Description: PGP signature


Reply to: