[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: critical problems in 2.3.5 prevent release



On Fri, Jun 08, 2001 at 10:10:42AM -0500, Stephen R Marenka wrote:
> 
> powerpc-utils wants to update a conffile. The prompt fails because stdin
> is /dev/null. You then get repeat 20 failures of dpkg because
> powerpc-utils never configures. This should be fixed in
> debootstrap-0.1.10. I usually hand-patch the woody script 
> (/usr/lib/debootstrap/scripts/woody if memory serves) to include
> --force-confold before I install base (while I wait for
> debootstrap-0.1.10 to show up ;-).

its in sid now.  i think the force-confold is the wrong solution
personally.  any package running into this problem is broken and
should be fixed.  --force-confold is treating the symptom, not the cause.

> You should be able to run nvsetenv at VT2? (or nvsetenv boot-device).

yes

> > yeah the quik stuff is pretty much going to fail unless you have a
> > 7200, 7300, or 7600.  
> 
> What else is needed? I can't fully test it, but I don't mind adding it.

depends on the machine, for beige g3s, and several others it needs
non-free, non-distributable Apple nvramrc patches. some need a
different load-base.  for others it requires a ritual goat sacrifice.
for some it just needs some unholy witchcraft etc...

one thing that would help is setting boot-command to that hack that
waits for the disk to spin up and tries again. 

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgpA7YD7lLICp.pgp
Description: PGP signature


Reply to: