[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Woody install report

Fri, May 11, 2001 at 05:39:21PM +0200 wrote:
> Hello,
> On Monday I had to install my new box and decided to go for Woody
> directly. This is my report.
thanks for the report.

> Install
> -------
> Ok, a normal floppies install. Oh, they were compiled for Spanish, so I
> could review the state of the translation.
> The install went flawless until modconf. There, first I noticed it
> wasn't in Spanish, and nearly any module had a description (description
> unavailable). I don't know why it wasn't in Spanish. manty said he got
> it in Galician just right, and I thought Joey had updated the Spanish
> translation.
This could be the problem, or at least the cause:

int configure_drivers (void) {
  struct stat statbuf;

  if (! NAME_ISEXE("/usr/bin/whiptail", &statbuf))
      symlink("/target/usr/bin/whiptail", "/usr/bin/whiptail");

  setenv("LANG", _("C"), 1);

Anybody know why we're setting the LANG to 'C' here, modconf keys off that in

>  Anyway, the big thing in modconf was when I tried to select
> 8139too in the net section.
> Selected the driver, pressed enter in the parameters dialog (without
> typing anything) and then I got a huge flood in console 1, which I had
> to stop with two ^C's. In C2 I saw there was a process,
> mv mv /etc/modules.199 /etc/modules.
ick, not sure about that one.

> In the network configuration, I had a small problem too. When I finished
> introducing the data (the last thing is DNS, right?), the installer
> froze. 
The only thing I can think of on this one is that the DNS entered was something
that dbootstrap had trouble parsing, there are two while loops that it might
have gotten stuck in.  I just tried a number of odd combinations of spaces,
numbers, etc, and couldn't recreate this.  Do you remember anythng about the DNS
servers, more than one? Possible typos?

> When I ^C'd, it gave me the welcome message, pressed enter and I
> was back in the network configuration.
That's good behavior in response to ^C, but not good that it froze.

> This time, there wasn't any
> freeze and I could go on into installing the base system using network.
> Using http.us.d.o (the default) wasn't nice, there are no Release files
That is wierd, it has always worked for me.  This was probably when
http.us.debian.org was down, I think that is the unhelpful error message you get
if the first wget fails for any reason.

> Rebooted, and after the first boot, I came across some other problems.
> First, debconf would whine about libterm-stool not installed, but dialog
I'm hoping these are fixed in the new debconf. 

> So, last run of base-config (with no pauses this time), dselect ran,
> which I ignored (installed nothing), and the installer threw me to the
> first login prompt.
> Immediately I upgraded to sid, and I guess that's the end of the story.
> I had problems with the default kernel. When I was trying to configure
> X, starting them would freeze my keyboard. I guess it was something with
> X, but then I tried gpm and same results. Gpm started, keyboard lock.
> Remotely killing gpm unlocked it. I just had to compile 2.4.4 and it
> went away.
I'm assuming these keyboard/gpm problems were after you upgraded to sid so I'm
not going to worry about them for now.

>  I think there's little more to say, the box's been working
> like a charm since I installed it.



Reply to: