[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

woody release task needs help: package priorities

Woody installation (via boot-floppies, base-config, tasksel, apt) will
change from Potato in that, normally, all packages marked as standard
will be marked for installation.

Citing Policy:

          These packages provide a reasonably small but not too limited
          character-mode system.  This is what will install by default if
          the user doesn't select anything else.  It doesn't include many
          large applications, but it does include Emacs (this is more of a
          piece of infrastructure than an application) and a reasonable
          subset of TeX and LaTeX.

This has never been done before by boot-floppies as a rather known
oversight, mostly because some many nasty and insecure and useless
packages are marked as standard.

I would appreciate it if someone or some team would work with archive
maintainers and work this out.

Here's a provisional list of packages which are standard or higher and
should not be:

  ae            not used as basic editor anymore, everyone seems to hate it
  setserial     rather inappropriate for non-i386, AFAIK
  libstdc++2.9  obsolete
  libident      why?  not used by other std package, pidentd
  exim          we should move to postfix, IMHO
  dpkg-ftp      obsolete
  rcs           few use it
  vacation      why standard?
  fingerd       not very secure for baseline
  ftpd          not very secure for baseline
  lpr           not very secure for baseline, poss use lprng?
  nfs-kernel-server  why standard in god's name?
  rblcheck      why standard?
  talk          rather obsolete, but debatable
  talkd         not very secure for baseline
  telnetd       not very secure for baseline

There are probably packages not in standard that should be, I'll leave
that to others.

.....Adam Di Carlo....adam@onshore.com.....<URL:http://www.onshored.com/>

Reply to: