[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing into DOS partition

Maisenbacher Matthias (K3/EMW4) * wrote:
> Hi,
> I was already asking this in debian-user, but nobody semmed to care.
> Now:
> I tried to install potato into a DOS partition.
> First try: umsdos
>   I copied umsdos.o into /tmp ann loaded it into the kernel,
>   but mount (in the boot flavour) wasn't able to mount -t umsdos.
>   When i (copied into /tmp and) tried the normal mount i got
>   problems because of the version of glibc.

You'll need to supply more information.  What is failing with umsdos.o?

Once you're able to mount, mount it on /target, the install routine
will accept that later.

> Second try: loop file system
>    No modules needed, but same problem with mount.

I installed potato into a file using loop (mount -o loop /mnt/file /target)
today, so this works, proven.

> Did i make any mistakes or is it really impossible to install Debian into a
> DOS partition?

It's not supported from scratch.

> Are there already any thoughts about improving that?

Provide proper patches :)

> Could I (until a Debian solution) use a statically linked mount?

If you find a way to move it around (if the floppies are too full)

> If this is the wrong list, please forgive
>  and point me to the right one.

Since some internal information is required, it's the proper one.



The only stupid question is the unasked one.
Oldenburger LinuxTag 2000                 http://oldenburger.linuxtage.de/

Reply to: