[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: loadlin bugreport

On Sun, 23 Jul 2000, Wichert Akkerman wrote:

> I can't reproduce this myself due to lack of machines with windows,
> so I didn't want to file a bugreport.

No windows machine handy either, but I do have an empty 2 gig
drive and installed DOS 5.0 on it for this.

> 1. copy linux, loadlin.exe and root.bin (from the images-1.22
> directory since it's impossible to copy an 1.44Mb image to a disk)
> to a DOS partition

I used the image-1.44  root.bin from compact, recompressed it and 
found "trailing garbage" had artificially inflated the file. 
At 950K, it fit on a 3.5 DOS floppy. 

> 2. Boot the machine in DOS
> 3. Run loadlin linux root=/dev/ram initrd=root.bin filesize=1.22

loadlin linux root=/dev/ram initrd=root.bin ro
Worked fine, although I didn't give it much of a test other than
to see the welcome screen (rescue 2.2.16) and complete a few options.

I already have a very nice potato installed via ethernet connection.
Beautiful job guys. :)  But can we somehow lose the floppy device
messages that appear on the screen?  (2.2.17-compact)

Also, the beer swilling penguin.. As soon as portmap loads, he loses
his colors and I'm stuck with a poor picture of him. Cirrus CL-GD542x
VLB on the video. Help!

Anyway, the loadlin method worked after I recompressed the image.

> This gives you: Can't find a valid ramdisk
> Writing root.bin to a floppy directly doesn't work since loadlin
> doesn't support initrd=/dev/fd0 .
> Booting the machine from floppy doesn't work for some reason, so
> we're somewhat stuck now :(
> Wichert.
> -- 
>   _________________________________________________________________
>  / Generally uninteresting signature - ignore at your convenience  \
> | wichert@liacs.nl                    http://www.liacs.nl/~wichert/ |
> | 1024D/2FA3BC2D 576E 100B 518D 2F16 36B0  2805 3CB8 9250 2FA3 BC2D |


Reply to: