[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

b-f: 2.2.5 installation report for i386


this is an installation report from erik. I told him he should use the
new 2.2.5 version from http://lully.debian.org/~aph/bf-2.2.5-i386/

The main problem is his proxy-port server.

ftp::proxy in apt.conf   doesn't work, if the environment variable

is set    export ftp_proxy=http://vulcain:3128/   (per ALT-F2)

then it works.  dbootstrap/apt-get ignores the :proxy entry in apt.conf


I'm on vacation from 28. Jan. to 6. Feb. in italy. 

WIll work on console-data-tools after that. 




this is a report of erikyyy@erikyyy.de
must be sent to koptein@debian.org
i hope this helps the debian project.
i'd love to get some email ;)

i have 2 computers. "vulcain" and "igno"
"igno" is the victim of installation
with 2.2.5 install disk.
conencted via network.
old p133 computer with 48 megs ram
and ne2000 network card
and soundblaster (the oldest model that exists)
and an 1.2 gigs ide lba harddisk

i created /tmp/debian
on vulcain and have
erik@vulcain:~/neudeb > /sbin/showmount -e vulcain
Export list for vulcain:
/tmp/debian *.yyydom

therein i put

from http://lully.debian.org/~aph/bf-2.2.5-i386/disks-1.44/
i downloaded
-rw-r--r--    1 erik     erik      1474560 Jan 27 13:57 driver-1.bin
-rw-r--r--    1 erik     erik      1474560 Jan 27 13:57 driver-2.bin
-rw-r--r--    1 erik     erik       702976 Jan 27 13:57 driver-3.bin
-rw-r--r--    1 erik     erik      1474560 Jan 27 13:58 rescue.bin
-rw-r--r--    1 erik     erik      1388544 Jan 27 13:58 root.bin

and put them into ~/neudeb, so NOT into the NFS dir.
i put each of them onto a disk with dd.

((the things i do are based on the knowledge of earlier debian
installations i made.))

IGNO: ((the name of the victim))

insert rescue floppy
syslinux (cool colors)
press enter
menu pops up. have seen  messages, scroll up.
see tons of "modprobe can't open dependencies file" messages.

i do /dev/hda3 as /
and /dev/hda1 as /boot  ((i hate lilo problems))
and /dev/hda2 as swap

now i shall select installation media
i see the new item "network - retrieve from network"

i do not trust that option and do not find it in the
installation documentation.
and i do not know how to use network without drivers.
so i select /dev/fd0
and do not even try the nfs or network option :-)

i am just disk jockeying the driver1-3 disks
cool the moving bar indicating success.
wondering how this is done i use the ps command on
the other console
and find the weird dbootstrap process...

oh shit. the last sector of drivers2 disk is dead.
he pops up a window "input output error"
and he wants disk2 again. good.

superformating the disk and putting driver2 on it again

((( why didn't the inventor of floppies make them faster)))

installed the ne driver
added option io=0x300 irq=12
does not show if it succeeded.
aeh? does leave module configuration window system without asking

now i configure network.

he sais no network interfaces found !!!!

hmm i do configure modules again
this time i do install the misc/ne module without optins
now he sais that it failed.

of course since i did not pass the options !

so i try again
this time with options
he just does not do anything.
does not display
but quits the configure module interface.

i switch to the console and install
8390 and ne manually with insmod

it perfectly works. with my options!!!

ok i do configure the network

i now install the base system via nfs
he should say that if not nameserver using
you must set server via IP address, not his hostname!

still those VERY confusing path selection dialogs
when doing nfs install
i always don't understand why it works in the end ;)))
but hey he is downloading base2_2 via nfs.


make system directly bootable from hard disk
he sais make bootable from /dev/hda3
now i understand why this is correct.
but i was confused at first because i mounted /dev/hda1 on /boot
and thought he would boot from /dev/hda1 now.

hmmm it worked so fast and i saw no output.
so i do a boot floppy to be safe.

while being bored i found tons of tons of Formatting cylinder x messages
on ALT-F3

oh my god. tons of messages scrolling by
telling drive write protected !!!
(but how could he superformat and mformat it ????)
bigshit that i cannot scrollback !!!!!!!!

mmh he sais "You've built your boot floppies
the moment of truth approaches..."

i think neither lilo nor boot floppy creation has worked but
i will reboot anyway.

i moved out the disk. it is not one of those half moved
copy protection disks where there is some ramdomness
in if copy protection is on , or off.
it is really NOT copy protected.

i see a lilo prompt
wow :-)

loading kernel.
hda3 was not cleanly unmounted
check forced....
thats not ok.

calculating module dependencies... depmod error reading elf header
no such file or directory....

SIOCSIFADDR no such device etc...
eth0 unknown interface...
(sure. i did only install it manually...)

create root
create erik
remove pcmcia

choose apt method.
i want manual entry
since i want copy sources.list from my server
and use squid http proxy to access the stuff
eh i have to use this dialog box.

ok if you want to. i enter my sources.list in the dialog box
deb ftp://ftp.de.debian.org/debian potato main non-free contrib
deb ftp://ftp.de.debian.org/debian-non-US potato/non-US main non-free contrib 
it's exactly those two lines.

how should i enter multiple lines ? hmmm just try the first line.
he sais he failed to fetch everything.
i must first edit apt.conf to change that ftp download
is done via http proxy

this is the file on my server:
  Get {
    Fix-Missing "true";

  Acquire {
    http {
      Proxy "http://localhost:3128/";;
    ftp {
      Proxy "DIRECT";
      Passive "true";
// Pre-configure all packages before they are installed.
// (Automatically added by debconf.)
DPkg::Pre-Install-Pkgs {"dpkg-preconfigure --apt";};

hmmm in man apt.conf there is no "Fix-Missing" explained !!!!!

mmmmmh. wondering how to change the file on igno.
must somehow trick the dialog

mhhhh. i will just write a apt.conf file:
  Acquire {
    http {
      Proxy "";;
    ftp {
      Proxy "DIRECT";
      Passive "true";
the ip above is my vulcain server with squid on it.

i will hope that the installation dialog not kills my apt.conf

testing with "manual entry" again. same errors.
i now edit sources.list by hand !!!!!!
then i run apt-get update by hand !!!

stupid same errors.

reading apt.conf manpage

now trying

Proxy "";;

still not working.
not working :-)
insmod network by hand...

now ping works
but it still does not work 

i try ftp_proxy ENVIRONMENT variable.
it works.
this is a thing i always hated on apt.
it is just no use to set the ftp::Proxy variable.
but if you set the ftp_proxy environment variable, it works.

he always sais 403 forbidden.

i try on the server
yes i knew it. ftp.de.debian.org is broken.
i now switch to ftp.debian.org

before that i edit /etc/hosts
and use vulcain instead of the ip adress in apt.conf
i hate the fact that ftp_proxy environment variable works
but in apt.conf the setting
Proxy "http://vulcain:3128/";;
does not do anything.

ok. apt-get update worked.

but what now ?
that stupid installation menu program does not accept what i do
i wonder if i could change it's environment by injecting
variables in /proc/pid/environment
but i won't try.

oh cool . i found out that the menu programs
"ftp" and "http" item should work.
but i cannot use the proxy !!!!!!!!
without the proxy i cannot do anything.

so what to do

i scan for "proxy" in the installtion docs
not found.
i ask #debian.de on irc.
wondering if other people on earth have full internet access
on all of their hosts...

i read /usr/doc/apt/examples but thats really not many information.
almost nothing.

nobody knows how to use a proxy !!!
neither http not ftp !

now what?

/me getting angry.

i am wondering who startet that menu.
cannot figure out.

i am lost.
for the first time since debian "bo"
i did not manage the installation.

giving up


----- End forwarded message -----

Reply to: