[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Booting problem with AMD Athlon


I recently bought Debian 2.1 and I tried to install it on my brand new PC.
However I was not capable to make it to the installer.

When I start from the CD-ROM, I see the boot: prompt, I hit return and then it starts loading stuff, like a normal boot does. However, when it arrives at the line
NCR53c406a: no available ports found
it hangs there.
The cursors waits at the beginning of the next line.

Here is my transcription of the log:
VP_IDE: IDE controller on PCI bus 00 dev 39
VP_IDE: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hda:DMA, hdb:pio
hda: JUBITSU MPE3136AT, ATA DISK drive
ide0 at 0x1f0-0x1f7, 0x3f6 on irq 14
ide1 at 0x170-0x177, 0x376 on irq 15
hda: FUJITSU MPE3136AT, 13031MB w/512kB Cache, CHS=1661/255/63
hdc: ATAPI 40X CD-ROM drive, 128 kB Cache
Uniform CDROM driver Revision: 2.55
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
NCR53c406a: no available ports found
_ (hangs here)

I looked in the Learning Debian book for boot arguments, and I found NCR53c406a corresponded to NCR 53c406a-based SCSI host adapters:

I have NO SCSI device on my computer, I only have an IDE HD. Therefore I find rather normal that it cannot find 'ports' for it since there are none.

I tried using max-scsi-luns=0 (and =1) arguments to prevent it to scan for SCSI device...it still hangs at the same point.

I tried using ncr53c406a=0 to disable interrupts and it didn't work too

I also tried disabling several BIOS options that could have lead to trouble...no luck.

But, when I gave boot arg pci=off, I got 2 extra lines before hangs:

NCR53c406a: no available ports found
eata_dma: No BIOS32 extensions present. This driver release still depends on it.
o Skipping can for PCI HBAs.

Some people told me that, because of my Athlon processor, I should try boot floppies with potato.

I made the floppies and was able to boot from the rescue floppy. It asked me for the root disk and I put it in.

It loads the the ramdisk, free some memory, then freezes.

here is the log:
VFS: Insert root floppy disk to be loaded into RAM disk and press ENTER
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 140k freed
_ <hangs here>

Here is the list of my hardware:
AMD Athlon 550 Mgz
1 IDE hard-disk: 13 gig
128 meg of RAM
Nothing SCSI
FUJITSU motherboard (AMI BIOS )
Sceptre Monitor 17 inch (VGA comptible)
S3 Trio3D/2X cheap graphic card
Ethernet card: StarTech

Do you have any idea of what could be wrong?

-Laurent Birtz

Alain Birtz
Qc, Canada
Internet: abz@videotron.ca, abirtz@cegepsth.qc.ca

Reply to: