[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems using latest build

"Craig H. Block" <pdxsj@pacbell.net> writes:

> After doing a "cvs up -A" this morning, I was able to successfully build
> the latest boot-floppies for the first time in a long while.  I must say
> that I was highly pleased.


> Ufortunately, I was not able to do much of
> an install with the product. I don't know if folks are real concerned
> with bf actually being able to install a system at this point, but here
> are the problems I had.

Yes -- we are at the point where we are concerned about this.

> Used a new disk with only an NTFS partition on it.  So I jumped over to
> tty2 and, happy-happy joy-joy, backspace worked.  Now if only I had
> command history :)   However, when I entered "fdisk" some wierd
> unintuitive prompt popped up that I couldn't make much sense of. So I
> Ctrl-C'd it and did the deed with cfdisk, good enough.

Hmmm...  I just tried fdisk.  It's changed a lot but it does seem to
work...  What "unintuitive" prompt are you talking about?  "Disk in
use" ?

> Things went fine until it was time to install the kernel and drivers. 
> In the past, dbootstrap would always allow me to just specify the CD and
> would "figure out" the rest by successivly pressing enter 3 times.  Not
> so.  I could not get it to extract the kernel and drivers from
> resc2880.bin and drivers.tgz off the CD.

No such file, resc2880.bin anymore.

>  I jumped over to tty2 and
> checked.  The CD was in fact mounted, although there was a mount error
> written under dbootstraps blue screen of secrecy.  BTW, I think
> redirecting dbootstraps stdout and stderr to tty3 is an extremely good
> idea.

Yes -- known issue.  We're planning on redirecting all stderr (mabye
stdout) to syslog and have a little tiny syslog in place, and 

> Anyway, I keyed in manual paths for everything but it kept saying it
> couldn't find rescue.bin.  Well that is strange because there is no
> file called rescue.bin in the release at least as far as I have ever
> noticed.

There is now...!  See my msgs to debian-cd and here over the last few
days.  This changed less than a week ago.

> I gave up at this point and shelled out to "halt" the system.  There is
> no halt.  There's a reboot, but no halt.  


> Like I said, I don't know how interested folks are with useability
> issues at this point, but I think that with only a little over a month
> left before the freeze (Jan 1 right?) it may be relevant at this time.

We have, um, about 7 weeks before the proposed freeze date.

We are concerned but these are all known problems.  I'll open up the
floodgates to testers when we are ready but it might not be for a
couple of weeks...

> BTW, I reviewed the stderr and stdout from buildtime and did not see any
> errors that have not been mentioned in this forum already.  Also I used
> "make build" instead of "make release."  Make build generates the three
> files I need and is faster than make release. I am making the assumption
> that this is an acceptable practice.  Let me know if not.  Make check is
> successful.

Never tried it...

.....Adam Di Carlo....adam@onShore.com.....<URL:http://www.onShore.com/>

Reply to: