[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: makedev fixes, etc.

On Tue, Apr 20, 1999 at 02:56:26PM +0200, Karl B. Hammar wrote:

> I resently did an install on an Transtac box, with a double aic7xxx
> something on the motherboard. The 2.0.36 kernel based resc.disc did fail,
> but when I put a vanilla 2.2.4 kernel on the resc.disc it did succed and I
> could finish the install. Also the SuSE made kernel based on 2.0.36 also
> worked.

I'm still waiting for a user here to tell me if the rescue disks I gave him
worked or not.  I know 2.2.x doesn't have this problems (2.2.5 contains aic
drivers 5.1.13) but the problem is we can't use 2.2.x on the rescue floppy. 
I tried several solutions: one is using a newer aic driver (5.1.15, 2.0.36
on the rescue floppy from 3/3 contains 5.1.11, IIRC), another one is using a
SuSE-like approach (like Slackware, they have tons of kernels compiled).  RH
doesn't have these problems because they use a totally different solution,
namely, an initial ramdisk from where modules are loaded _after_ the kernel

> So whatever didn't work on 2.0.36 is fixed with 2.2.4 for this
> motherboard, and also SuSE made something work for 2.0.36.

Would someone take a look at their kernel sources? I had a few problems
installing 5.1.15 over a debianized kernel source for 2.0.36 (2.0.36-3),
because there are some other SCSI patches already applied (MCA SCSI I
recall, but that wasn't a really problem)

> Fetch patch in e.g. ftp://ftp.uk.kernel.org
> /pub/linux/kernel/people/alan/2.0.37pre/2.0.37/2.0.37-pre-patch-9.bz2,
> and a vanilla 2.0.36 kernel (I have not tested it against debian's 2.0.36),
> in /pub/linux/kernel/linux-2.0.36.tar.gz

I also did this.  It's using aic drivers 5.1.13, I _think_ (/me has lousy
memory), but I guess it's not going to be that easy to convince Richard to
let in a different kernel for slink.

Asking arround I found a few more machines with 788x's on them... this is
going to sound stupid, but I better ask anyway.  The funny thing with these
machines is they _do_ have onboard 788x's but they don't have _any_ SCSI
device attached.  Would the precense of the host adapter alone trigger the
problem? I have to talk the people in charge of these boxes into "letting me
power cycle them just to test a boot floppy -- it'll be a just few minutes
downtime... promise!", but I don't want to find out the boot floppies work
just because nothing is attached to the adapters...


Reply to: