[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Image created by simple-cdd work in qemu but not in real life

Am Sonntag, 20. Juli 2008 12:03 schrieb Jabka Atu:
> Howdy,...
> I created an image using simple-cdd and tested in qemu.
> It worked fine (all went as it should).
> When i burn it on a cd and reboot from it :
> the image stuck saying :
> "Uncompressing Linux... OK,booting the kernel"
> if i press alt+f4 i can see the logs (but can't see any errors).
> alt+f2/f3 allow shell (ash)
I don't know what went wrong. But if your CD works with qemu and not 
with a real PC, you may use a serial console in qemu, which is not 
connected to your real PC?

Best thing you may do, to track the problem is,
boot in qemu with priority=medium or low, load the ssh-client udeb and 
execute the shell udeb from the menu. You must boot in text mode, to 
make this work.

Then post the content of /proc/cmdline
and the content of your profiles/*postinst

then one may see if there are any mistakes

> i also tried manualy starting d-i but i don't know yet how to use
> simple-cdd configurations :
> so it will use presed postinst etc from /cdrom/simple-cdd
> What am i doing wrong ?


	Harry Jede

Reply to: