[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

pidgin-data 2.6.3-1~bpo50+1 brakes pidgin

Just a moment ago I have upgraded to pidgin-data 2.6.3-1~bpo50+1 which uninstalled my pidgin2.6.2-1~bpo50+2. I cannot install pidgin 2.6 anymore now:

$ sudo apt-get install pidgin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pidgin: Depends: pidgin-data (< 2.6.2-z) but 2.6.3-1~bpo50+1 is to be installed Depends: libpurple0 (>= 2.6.0) but it is not going to be installed
E: Broken packages

It already happened in past, about 2.4.2 > 2.4.3 upgrade.

I guess that pidgin-data and pidgin should be provided in compatible versions to avoid such broken upgrades.

Now I have to revert to pidgin 2.4.3 until pidgin 2.6.3 is available. This takes pinning 3 packages: lipurple0, pidgin, pidgin-data at version 2.4.3.
Reply to: