[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: samba unmet dependencies

Quoting Wolfgang Granzer (w@auto.tuwien.ac.at):

> May be I have missed the point but I am still not able to upgrade to
> the backports package of libpam-smbpass:
> The following packages have unmet dependencies:
>   libpam-smbpass: Depends: libpam-runtime (>= 1.0.1-6) but
> 1.0.1-5+lenny1 is installed
> Does your fix also affect the libpam-smbpass package?

It should have but it didn't. Indeed, the dependency *can* be relaxed
to 1.0.1-2ubuntu1 as the change to PAM config files that requires
libpam-runtime 1.0.1-6 is already dropped from backported packages.

So, the fix the libpam-smbpass is just relaxing the dependencies: no
other change. As a consequence, you can safely force the installation
of the package by ignoring the dependency requirements (download the
.deb files and install them with "dpkg
--ignore-depends=libpam-runtime"). This, until I reupload fixed
packages of course.

Reply to: