[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Failure to upgrade to samba backport


When I try to upgrade my current samba installation to the one
available in backports it fails with some dependencies errors, and I
do not see how to resolve them:

petole:~# apt-get -t lenny-backports install samba
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  samba: Depends: samba-common (= 2:3.3.4-1~bpo50+1) but  2:3.2.5-4lenny2 is to be installed
         Depends: libgnutls26 (>= 2.5.9-0) but 2.4.2-6+lenny1 is to be  installed
         Depends: libgssapi-krb5-2 (>= 1.6.dfsg.2) but it is not  installable
         Depends: libk5crypto3 (>= 1.6.dfsg.2) but it is not  installable
         Depends: libkrb5-3 (>= 1.7dfsg~alpha1) but it is not  installable
         Depends: libtalloc1 (>= 1.2.1) but 1.2.0~git20080616-1 is to  be installed
E: Broken packages

What can I do to resolve these dependencies errors ?

My /etc/apt/sources.list is:

# standard sources
deb http://ftp.fr.debian.org/debian/ lenny main contrib non-free
deb http://security.debian.org/ lenny/updates main contrib non-free
#deb-src http://ftp.fr.debian.org/debian/ lenny main

# volatile
deb http://volatile.debian.org/debian-volatile lenny/volatile main

# backports
deb http://www.backports.org/debian lenny-backports main
#deb-src http://www.backports.org/debian lenny-backports main


Reply to: