[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel 2.6.22-4 (Waiting for root filesystem)

Vladimir Komendantsky wrote:

Can anyone explain why after installation of the backport.org kernel
2.6.22-4 onto debian etch this kernel doesn't boot? I've done the
installation using apt-get and aptitude and I wonder why I can't make
this thing work.

The screen output is below (just wrote down from the screen - there
was no logging available):

Begin: Mounting root file system...
Begin: Running /scripts/local-top...
Begin: Waiting for root filesystem...
Marking TSC unstable due to possible TSC halt in C2
Time: acpi_pm clocksource has been installed.

Then there is a long delay after which it eventually arrives with the following:

ALERT: /dev/hda2 does not exist. Dropping to a shell!

However, BusyBox prompt is not functional and only cold reboot works out then.

I found somewhere in the support forums that the problem is likely to
be connected with renaming /dev/hda -> /dev/sda since the etch kernel
2.6.18. There was a possible solution using partition labels of the
kind, say, LABEL=a-root instead of /dev/hda2 in /boot/grub/menu.lst
and /etc/fstab.

I tried renaming hda to sda in grub's menu.lst but that didn't help.
Then I labelled all partitions but the root ReiserFS one since I don't
know if there is a way to label it when it's mounted and there is no
reiserfstune in the rescue mode of my etch installtion cd (which would
be the only capable tool known to me).

Can this problem with the kernel be really solved by introducing
partition labels?

I've never had a problem with the changing hda<==>sda.  However,
I did experiment with putting jfs on a root partition, and the
2.6.22 wasn't doing a clean shutdown, so the partition was never
being marked as clean, thus forcing a fsck condition.  Since
jfs.fsck wasn't in the initrd, it would always fail.  My solution
was to change the root partition back to ext3.
A friend and I were chatting tho, and another solution might be
to add the reiserfstune to your initrd, so that it's available
at boot time.  You might be able to add some stuff by adding
it to /etc/initramfs-tools/modules, and then rerun
update-initramfs.  Not sure if this will work or help, but if
you try, I would be interested in your results.


Mark Paulus
2424 Garden of the Gods Rd  | Phone:  v622-5578 / 719-535-5578
0419/117 - LEC Access ; D5-1010   | FAX:    719-535-1665
Colo Springs, CO  80919    | 1800PageMCI / 1406052
AIM : mgpaulus1    /  sametime : mark.paulus

fn:Mark Paulus
org:MCI;Lec Interfaces / 40419
adr;dom:;;2424 Garden of the Gods Rd;Colorado Springs;CO;80919
title:Mark Paulus
tel;pager:800-pagemci / 1406052

Reply to: