[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kernel 2.6.22-4 (Waiting for root filesystem)


Can anyone explain why after installation of the backport.org kernel
2.6.22-4 onto debian etch this kernel doesn't boot? I've done the
installation using apt-get and aptitude and I wonder why I can't make
this thing work.

The screen output is below (just wrote down from the screen - there
was no logging available):

Begin: Mounting root file system...
Begin: Running /scripts/local-top...
Begin: Waiting for root filesystem...
Marking TSC unstable due to possible TSC halt in C2
Time: acpi_pm clocksource has been installed.

Then there is a long delay after which it eventually arrives with the following:

ALERT: /dev/hda2 does not exist. Dropping to a shell!

However, BusyBox prompt is not functional and only cold reboot works out then.

I found somewhere in the support forums that the problem is likely to
be connected with renaming /dev/hda -> /dev/sda since the etch kernel
2.6.18. There was a possible solution using partition labels of the
kind, say, LABEL=a-root instead of /dev/hda2 in /boot/grub/menu.lst
and /etc/fstab.

I tried renaming hda to sda in grub's menu.lst but that didn't help.
Then I labelled all partitions but the root ReiserFS one since I don't
know if there is a way to label it when it's mounted and there is no
reiserfstune in the rescue mode of my etch installtion cd (which would
be the only capable tool known to me).

Can this problem with the kernel be really solved by introducing
partition labels?


Reply to: