[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Missed dependency for postgresql backport

* Xavier Poinsard <xpoinsard@openpricer.com> [2008-04-01 11:13:40 CEST]:
> Gerfried Fuchs a écrit :
> > * Xavier Poinsard <xpoinsard@openpricer.com> [2008-03-31 10:33:01 CEST]:
> >> Today, when I upgraded the postgresql packages, aptitude proposed me to
> >> remove libpq5 which leads to broken installation.
> > 
> >  On what architecture?
> i386

 Thanks for your exhaustive additional informations. In what way did
aptitude propose you this? Did it list broken dependencies, anything?
Can you maybe send your aptitude log file along?

 Sorry, if you don't give any informations I'm not able to help you or
reproduce your problem. The postgres package version 8.3.1-1~bpo40+1
depends on postgresql-8.3 which in turn depends on libpq5 (>= 8.3~beta1).
The only way I can see you having a problem is that you have missing
preferences for all the involved packages (including e.g.
postgresql-client-common). Due to your immense informations in your
mails this is quite likely. Or not.

 So long,

Reply to: