[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Pinning

Anthony DeRobertis wrote:
On 01/11/2008 03:58 PM, Paweł Jaworski wrote:

So I installed it using "apt-get -t etch-backports openoffice.org", but it will prevent it from automatic updates...

No it won't. Apt will see that the version in stable is older, and thus ignore it. That'll leave bpo as the highest-priority source.

$ apt-cache policy openoffice.org
 Installed: 1:2.3.1-2~bpo40+1
 Candidate: 1:2.3.1-2~bpo40+1
 Version table:
*** 1:2.3.1-2~bpo40+1 0
       100 http://www.backports.org etch-backports/main Packages
       100 /var/lib/dpkg/status
    2.0.4.dfsg.2-7etch4 0
       500 http://http.us.debian.org etch/main Packages
       500 http://security.debian.org etch/updates/main Packages

Yes, but I want another version (for example 2.3.2) to be installed automatically. I don't see any solution except for adding openoffice.org, openoffice.org-writer, openoffice.org-calc ... whole the mess to my apt/preferences. Are there any tricks?

Best regards
Pawel Jaworski

P.S. Scribus went all right only with Scribus alone in preferences.

Reply to: