[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Accepted amavisd-new 1:2.3.3-2bpo1 (source all i386)


As reported to the Debian BTS (bug #348439), the libcompress-zlib-perl 
dependency version should be changed to 1.35.

On a standard Sarge system, the current backport will not work. When starting
the amavis daemon it will fail with the following error message:

  Starting amavisd: Problem in the Amavis::Unpackers code: Compress::Zlib
  version 1.35 required--this is only version 1.34 at (eval 39) line 18.
  BEGIN failed--compilation aborted at (eval 39) line 18.

This can either be fixed by using the libcompress-zlib-perl backport or
changing the following line in /usr/sbin/amavisd-new

  use Compress::Zlib 1.35;  # avoid security vulnerability in <= 1.34

to read

  use Compress::Zlib 1.34;

which might open some security vulnerability which seems to exist in versions
<= 1.34 (didn't check up on that, though).

This is not a big deal - just thought it should be fixed ;-)

Sebastian "tokkee" Harl
GnuPG-ID: 0x8501C7FC

Attachment: signature.asc
Description: Digital signature

Reply to: