[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: MP30-AR0 arm64 sdcard slot not detected

W dniu 20.10.2019 o 20:48, Michael Howard pisze:
> On 20/10/2019 17:40, Steve McIntyre wrote:

I did not played with Gigabyte board. Have APM Mustang under desk (but
not used it for a while).

>> First question: how are you booting the system? U-Boot or UEFI?

> Both :) My approach with this board has been to chainload UEFI from 
> u-boot , the board in the same state as it arrived a few years back. 

Can not it be flashed with UEFI to skip U-Boot part?

> With a centos 4.5 kernel I get the mmc slot as I do with mainline 4.2
> and debian.
> With newer kernels, no mmc slot.

Boot last kernel which worked, check kernel messages, modules, device
tree. Compare with one when it does not work. Share results.

> Ultimately, I wanted to use the four sata slots for iSCSI but that 
> leaves me with no OS. I could of course just use the 4.2 kernel that 
> works but I want to know why ....

Have you considered adding PCI Express cards? NVME, SAS controller?

I used my Mustang with PCIe -> NVME adapter card and NVME in it. Worked
fine but had to keep /boot/ /boot/efi on USB stick as last version
(3.06.25) of Mustang firmware did not recognized NVME.

> USB sucks on this board (and so might the mmc slot), an install to 
> usb takes in the order of 10 times the time to install to sata.

X-Gene USB is USB 2.0 speed only.

Reply to: