[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Installer on Pine64+ (no serial console)

On 07/05/19 07:06, Andrei POPESCU wrote:
On Ma, 07 mai 19, 00:33:19, peter green wrote:
On 04/05/19 18:49, Andrei POPESCU wrote:
This prompted me to reinstall my pine64 which has been sitting idle
for a while, since the old install (based on a vendor image) on it
stopped booting. Your instructions worked fine and after installation
the system sucessfully rebooted to a login prompt.
Great :)
At that point I got distracted, when I came back a day or so later I
found that the Ethernet interface had stopped working. It appeared to
be up and had an IP address (meaning it must have passed some packets
since the reboot), but no traffic was getting through. Downing and
re-upping the interface brought it back to life. I also rebooted the
system and found the network interface had come up successfully after
the reboot.

Then I ran into another problem. I have a SATA hard disk connected by
a startech USB to SATA/IDE adapter (I belive its
though I'm not using the PSU that came with it). When I tried to rsync
a large file (an image of the pre-reinstall SD card contents) to said
drive it dropped out. I unmounted and re-mounted the drive (which had
renamed itself from sda to sdb after the dropout) and tried again, but
the same happened again.
As usual with this kind of devices, do make sure you have a good power
source (for the PINE A64 ideally via the Euler bus instead of the
micro-USB connector).
Right now i'm using a 5V 4A brick from stontronics. The output from this is split to feed the pine (currently via micro usb) and the HDD. One of the reasons I chose the particular USB to SATA adapter I did is because it is only a data adapter, allowing me to do the power the way I want it.

I have just tried a different USB to SATA adapter, this one unfortunately uses a combined data and power connection to the drive, but it has a second USB plug for power, so I chopped up a USB extension and used it to connect said second USB plug direct to the power supply. I figured the pine64 would probably tolerate (and may even benefit from) any backfeeding of it's USB device ports this caused.

After the swap I was able to complete the rsync successfully. So it seems that some issue with the USB to SATA adapter I was using (either with the adapter in general or a compatibility issue between the adapter and the pine) was to blame.

Connecting external drives without own power or via a powered USB hub is
just asking for trouble :)

Kind regards,

Reply to: