[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian and wol on Buffalo Linkstation WXL

sorry.. the original message is a bit fuzzy.. I forgot to put it in plain text: this is the clean version:

I have an old Buffalo Linkstation Duo (WXL), that now I would like to use as a backup for my new NAS I've bumped into RogerShimizu's presentation at https://miniconf.debian.or.jp/assets/files/Debian%20Installer%20for%20Buffalo%20Linkstation%20NAS.pdf, in order to update a bit the system with a fresh new debian install; I followed it and I now have a running Debian system , but:

ᅵᅵ --ᅵᅵᅵ the only way to shutdown the unit is to put the physical button in the off position, otherwise both poweroff and shutdown commands lead to a reboot of the unit

ᅵᅵ -- ᅵᅵ wakeonlan is not available:
ᅵᅵᅵᅵᅵᅵᅵ ethtool responds "Supports Wake-on: d", and trying to set it ends in:ᅵ "Cannot set new wake-on-lan settings: Operation not supported"

> a@debian:~$ sudo ethtool eth0
> Settings for eth0:
>ᅵᅵᅵᅵ Supported ports: [ TP MII ]
>ᅵᅵᅵᅵ Supported link modes:ᅵᅵ 10baseT/Half 10baseT/Full
>ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 100baseT/Half 100baseT/Full
>ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 1000baseT/Full
>ᅵᅵᅵᅵ Supported pause frame use: Symmetric Receive-only
>ᅵᅵᅵᅵ Supports auto-negotiation: Yes
>ᅵᅵᅵᅵ Advertised link modes:ᅵ 10baseT/Half 10baseT/Full
>ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 100baseT/Half 100baseT/Full
>ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 1000baseT/Full
>ᅵᅵᅵᅵ Advertised pause frame use: No
>ᅵᅵᅵᅵ Advertised auto-negotiation: Yes
>ᅵᅵᅵᅵ Link partner advertised link modes:ᅵ 10baseT/Half 10baseT/Full
>ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 100baseT/Half 100baseT/Full
>ᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵᅵ 1000baseT/Full
>ᅵᅵᅵᅵ Link partner advertised pause frame use: Symmetric Receive-only
>ᅵᅵᅵᅵ Link partner advertised auto-negotiation: Yes
>ᅵᅵᅵᅵ Speed: 1000Mb/s
>ᅵᅵᅵᅵ Duplex: Full
>ᅵᅵᅵᅵ Port: MII
>ᅵᅵᅵᅵ PHYAD: 8
>ᅵᅵᅵᅵ Transceiver: internal
>ᅵᅵᅵᅵ Auto-negotiation: on
>ᅵᅵᅵᅵ Supports Wake-on: d
>ᅵᅵᅵᅵ Wake-on: d
>ᅵᅵᅵᅵ Link detected: yes

obviously with the original buffalo firmware, it worked!

I've tried, under Roger's suggestion, to add "marvell" to /etc/initramfs-tools/modules, but nothing changed: it seems that the NIC is not enable for wakeonlaᅵ (even if it was, of course)

now I'm wondering if it could be a driver issue, and if is there any other module that can be used instead of the mv643xx_eth

> a@debian:~$ sudo dmesg |grep eth
> [ᅵᅵᅵ 0.022487] [Firmware Info]: /ocp@f1000000/ethernet-controller@76000/ethernet1-port@0: local-mac-address is not set > [ᅵᅵ 20.475943] mv643xx_eth: MV-643xx 10/100/1000 ethernet driver version 1.4 > [ᅵᅵ 20.593063] mv643xx_eth_port mv643xx_eth_port.0 eth0: port 0 with MAC address 00:24:a5:47:96:af
> [ᅵᅵ 34.213593] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
> [ᅵᅵ 36.875031] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 1000 Mb/s, full duplex, flow control disabled
> [ᅵᅵ 36.885480] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

and now I'm stuck here... My idea to use this old unit as a "semi-remote" (in the same LAN)backup of the new NAS doesn't work, if I'm not able to switch it off and on when neededl

any suggestion?

thanks in advance


Reply to: